0.7.9 Linux release from ayufan
#11
Oh, Ubuntu. In Debian I can't even find out what libglvnd-dev is. But I just built Firefox 61 which uses GTK 3 (dev).
#12
This is the information I have for the package:

Package: libglvnd-dev (1.0.0+git20180308-3)

Vendor neutral GL dispatch library -- development files

This is an implementation of the vendor-neutral dispatch layer for arbitrating OpenGL API calls between multiple vendors on a per-screen basis.
Thanks for the tip I will try out the debian images after work today.

Also does the onboard sound work out of the box for others using Ubuntu and or Debian?
#13
(08-05-2018, 02:37 PM)ab1jx Wrote: Also does the onboard sound work out of the box for others using Ubuntu and or Debian?

Sound I'd like to find out about.  I can't make my HDMI sound work but I didn't try very hard.  https://forum.pine64.org/showthread.php?...4#pid39414 I have a good USB sound card I can use, didn't worry about it..

"onboard"?  what's that?  The choices I saw were HDMI, I2C, SPDIF.  Onboard sound on a Raspberry Pi is done with PWM, that could maybe be done here using GPIO pins.  I don't know what's fed to the A/V jack.

Rock64pro HDMI sound works I hear.

Try "alsactl init" then "aplay -l" on a command line.
#14
Hello,

I have been trying to get sound out of the headphone jack but selecting this does not produce sound when playing music or videos, but a USB soundcard works well.
#15
   
The schematic page 17 shows this audio circuitry but I don't know how you access it from software.
#16
(08-06-2018, 10:24 AM)nislaco23 Wrote: I have been trying to get sound out of the headphone jack but selecting this does not produce sound when playing music or videos, but a USB soundcard works well.
I have not been able to get anything out of the headphone jack, but have no issues through HDMI. (My sound demands are Noddy - if I can hear an mp3 play I am happy!)
* ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Started Bionic minimal - now eoan, Openbox desktop for general purpose daily PC.
* PinePhone BraveHeart on order
#17
There is sound here (Vestel 22L1333G TV/monitor, LXDE image), but it plays back several times faster than it should, i.e. at a much higher sample rate. (The www.audiocheck.net site contains a lot of interesting sounds that I used to test this.)
#18
(08-07-2018, 03:41 AM)lucho Wrote: There is sound here (Vestel 22L1333G TV/monitor, LXDE image), but it plays back several times faster than it should, i.e. at a much higher sample rate. (The www.audiocheck.net site contains a lot of interesting sounds that I used to test this.)
This is a known issue with pulseaudio with the 4.4.132-1075 kernel that is default in the 0.7.9 Ayufan release.

You can check your kernel version with
uname -a

You can upgrade your kernel with
sudo apt-get update
sudo apt-get install linux-image-4.4.132-1083-rockchip-ayufan-gfd3f12ca5fae
and reboot
* ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Started Bionic minimal - now eoan, Openbox desktop for general purpose daily PC.
* PinePhone BraveHeart on order
#19
I've installed Bionic LXDE, but I'm not having any success getting it to autologin. Any suggestions?


Code:
sudo vi /etc/lightdm/lightdm-gtk-greeter.conf.d/lightdm.conf


Added the following lines:


Code:
[SeatDefaults]
greeter-session=lightdm-greeter
greeter-hide-users=true
session-wrapper=/etc/X11/Xsession
autologin-user=rock64


Upon reboot, it still requests login. I've tried several different variations of the above file. I've also tried moving lightdm.conf directly into the /etc/lightdm folder.

I'm thinking that lightdm isn't looking in this directory (or perhaps it isn't functioning properly) because the desktop background specified in the same folder in 99_xxx_rock64.conf isn't loading either.
#20

If I do cat /proc/asound/cards I see:
Code:
 0 [HDMI           ]: HDMI - HDMI
                      HDMI
 1 [I2S            ]: I2S - I2S
                      I2S
 2 [SPDIF          ]: SPDIF - SPDIF
                      SPDIF

I'm guessing the AV jack is on the I2S because the other two are digital output.  And maybe the amp/driver chip is connected to the I2S bus.  Haven't tried it.

If I type alsamixergui on a command line I see this message to its stderr: "No mixer elems found".

I can do ls /dev/snd and see stuff in there, but there's no /dev/dsp

I'm trying to get HDMI sound working, at this point about the same troubleshooting steps.  This could all be missing drivers.  Audacity shows these device choices:
   


Possibly Related Threads...
Thread Author Replies Views Last Post
  Release 0.9.14 Ubuntu Mate desktop, LXDE, OMV, Docker CE (container) Luke 1 371 12-10-2019, 01:30 PM
Last Post: Helium75
  Rockpro64 and stock arch linux TaborFife 1 254 11-29-2019, 12:18 PM
Last Post: Yoast
  Ayufan 5.4.0 rc1 release - cannot boot Mentaluproar 1 124 11-27-2019, 04:26 AM
Last Post: dukla2000
  Reboot problem on latest ayufan and 4.4 /dev/null 2 288 11-27-2019, 04:23 AM
Last Post: dukla2000
  poor HDD performance - ayufan mainline OMV Mentaluproar 0 58 11-11-2019, 10:26 PM
Last Post: Mentaluproar
  My PCIe disk controller works with Linux 5.3.6 guannais 1 134 10-30-2019, 07:11 PM
Last Post: guannais
  Linux Build Help: Stuck at "Starting kernel ..." ihamilton 2 279 10-10-2019, 12:51 PM
Last Post: ihamilton
Big Grin Feature Complete Debian Desktop Release Mrfixit2001 152 17,420 10-09-2019, 05:42 PM
Last Post: bcnaz
  Void Linux WIP losinggeneration 0 189 10-04-2019, 03:23 AM
Last Post: losinggeneration
  Arch Linux on RockPro64 mmatyas 27 8,991 09-28-2019, 04:30 AM
Last Post: TaborFife

Forum Jump:


Users browsing this thread: 1 Guest(s)