PinePhone Pro Explorer's edition Qualcomm modem recovery
(01-16-2024, 09:34 AM)shifras Wrote: Yea, i know. Same happened to me. First time it failed. So i tried again, but instead of seeing success, it failed again. And qualcomm option dissapeared. Since then it is not listed in devices /dev/ directory. Also $ fwupdmgr get-devices does not list quectel modem. I am sure modem needs to be booted into EDL mode as in regular PP by shorting test points on the board, but on the pro i have no idea how to do that, because they are not marked.I opened a ticket in pine64 support. They instructed me to perform hardware test in their android build, which i did. Exported a test result and sent them. Second day still no answer as of yet. I will update of the progress, but i am actually very motivated to hear any suggestions up untill then since this can happen to anyone and would really be awesome to find a recovery solution.

Here is my output of 'cd /dev/' and lsusb

[alarm@danctnix ~]$ cd /dev/
[alarm@danctnix dev]$ ls
autofs           fd         i2c-5        loop3         mmcblk1p1     port   ptyp8   shm       tty14  tty26  tty38  tty5   tty61  ttyp7    ttyUSB1       v4l-subdev3  vcs6   vcsu3    video5
block            full       i2c-9        loop4         mmcblk2       ppp    ptyp9   snapshot  tty15  tty27  tty39  tty50  tty62  ttyp8    ttyUSB2       v4l-subdev4  vcs7   vcsu4    video6
btrfs-control    fuse       iio:device0  loop5         mmcblk2boot0  psaux  ptypa   snd       tty16  tty28  tty4   tty51  tty63  ttyp9    ttyUSB3       v4l-subdev5  vcsa   vcsu5    video7
bus              gpiochip0  iio:device1  loop6         mmcblk2boot1  ptmx   ptypb   stderr    tty17  tty29  tty40  tty52  tty7   ttypa    uhid          v4l-subdev6  vcsa1  vcsu6    video8
cdc-wdm0         gpiochip1  iio:device2  loop7         mmcblk2p1     pts    ptypc   stdin     tty18  tty3   tty41  tty53  tty8   ttypb    uinput        v4l-subdev7  vcsa2  vcsu7    video9
char             gpiochip2  iio:device3  loop-control  mmcblk2p2     ptyp0  ptypd   stdout    tty19  tty30  tty42  tty54  tty9   ttypc    urandom       v4l-subdev8  vcsa3  vfio     zero
console          gpiochip3  input        mapper        mmcblk2rpmb   ptyp1  ptype   tty       tty2   tty31  tty43  tty55  ttyp0  ttypd    userfaultfd   v4l-subdev9  vcsa4  video0   zram0
core             gpiochip4  kmsg         media0        mqueue        ptyp2  ptypf   tty0      tty20  tty32  tty44  tty56  ttyp1  ttype    v4l           vcs          vcsa5  video1
cpu_dma_latency  hugepages  kvm          media1        mtd           ptyp3  random  tty1      tty21  tty33  tty45  tty57  ttyp2  ttypf    v4l-subdev0   vcs1         vcsa6  video10
cuse             i2c-0      log          media2        mtd0          ptyp4  rfkill  tty10     tty22  tty34  tty46  tty58  ttyp3  ttyS1    v4l-subdev1   vcs2         vcsa7  video11
disk             i2c-1      loop0        media3        mtd0ro        ptyp5  rtc     tty11     tty23  tty35  tty47  tty59  ttyp4  ttyS2    v4l-subdev10  vcs3         vcsu   video2
dri              i2c-3      loop1        mem           net           ptyp6  rtc0    tty12     tty24  tty36  tty48  tty6   ttyp5  ttyS3    v4l-subdev11  vcs4         vcsu1  video3
fb0              i2c-4      loop2        mmcblk1       null          ptyp7  serial  tty13     tty25  tty37  tty49  tty60  ttyp6  ttyUSB0  v4l-subdev2   vcs5         vcsu2  video4
[alarm@danctnix dev]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 2c7c:0125 Quectel Wireless Solutions Co., Ltd. EC25 LTE modem
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[alarm@danctnix dev]$

Messages In This Thread
RE: PinePhone Pro Explorer's edition Qualcomm modem recovery - by mikehenson - 01-17-2024, 08:27 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinephone pro shuts down immediately after login covar 4 247 07-03-2024, 10:59 AM
Last Post: covar
  PinePhone Pro EDL boot by shorting contacts ozkenlc 2 574 06-11-2024, 02:14 PM
Last Post: TX1683
Thumbs Up Pinephone Pro + Keyboard for sale Jimmy88 2 1,047 04-22-2024, 08:38 PM
Last Post: AegisWages
  PinePhone only turns on sometimes zvavybir 1 573 03-27-2024, 12:19 PM
Last Post: zvavybir
  Failed firmware change for the Quectel EG25GGBR07A08M2G modem of PPP Explorer Edition andrey 1 562 02-17-2024, 12:32 PM
Last Post: traut
Question Screen turning off and booting problems with the Pinephone Pro xnZwJR6vys9a2wm7yWE4 0 352 01-16-2024, 02:38 PM
Last Post: xnZwJR6vys9a2wm7yWE4
  Pinephone Pro LCD and Touchscreen Hobgoblin 8 4,350 01-14-2024, 02:50 PM
Last Post: shifras
  Messed Up Modem dorkydev 13 2,632 12-23-2023, 03:02 PM
Last Post: dorkydev
  Recurrent problems with broken charger chip on the pinephone/pinephone pro keyboard Jite 4 1,486 11-18-2023, 07:25 AM
Last Post: crocspot
  Bypass contact points on PPP developer edition cyrelk 1 1,351 10-10-2023, 10:23 AM
Last Post: fxc

Forum Jump:

Users browsing this thread: 1 Guest(s)