Correct setup for u-boot and fstab ? Device not booting
#8
@as365n4 Well, if you compile it for the H6 there are a couple of differences:

When building arm-trusted-firmware, select the h6 platform:

Code:
make CROSS_COMPILE=aarch64-linux-gnu- PLAT=sun50i_h6 bl31

The binary it produces is a ".bin" not a ".elf". Therefore, when linking it from u-boot do as follows:

Code:
ln -s ../arm-trusted-firmware/build/sun50i_h6/release/bl31.bin bl31.bin

And then when building:

Code:
make -j15 CROSS_COMPILE=aarch64-linux-gnu- BL31=bl31.bin all u-boot.itb

=> When building u-boot for different boards there is more to do than just selecting a different config.

Also, when flashing the Image youz have to use different offsets. For Allwinner boards:

Code:
dd if=u-boot-sunxi-.... of=/dev/sdX bs=1024 seek=8 conv=notrunc

Btw.: The differences between config sizes are not due to support status. Often, the configs include other configs, so if there is not soo much special about the Pine H64 when compared to other Allwinner H6-based boards this results in a much smaller config.

However, I had issues with ethernet on the H6 as well. See this thread: https://forum.pine64.org/showthread.php?tid=10645
  Reply


Messages In This Thread
RE: Correct setup for u-boot and fstab ? Device not booting - by kuleszdl - 01-11-2021, 12:11 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  U-boot not booting on H64 model B CGNZVV 2 1,447 06-08-2022, 10:32 AM
Last Post: as365n4
  Unable to boot any armbian linux vicsanca 6 5,711 10-17-2019, 12:08 PM
Last Post: JGwinner

Forum Jump:


Users browsing this thread: 1 Guest(s)