Exclamation Mark on Cellular
#1
Hello all!

 I got this PinePhone about a month ago, and so far, Arch has been the fastest on it! However, I have noticed that there is now an exclamation mark on the cellular signal on the top bar. I would have put the picture here, but I don't understand how to do that in this forum. Here is the link to the picture: https://drive.google.com/file/d/1FWJKroX...sp=sharing I tried Manjaro Phosh on a microSD and after updating, it too had the exclamation mark. In Arch, I tried another sim card (the first was AT&T, the second was Verizon), but it still showed the exclamation mark. The only damage I know of on the sim card slot is that one of the prongs is a little bent after trying to use the included SIM card adapter (that is a whole different story). However, the sign didn't show up before and calls and texts worked and still work even with the mark (though I haven't tested it thoroughly). Also, the modem details seem fine in Arch, but they sometimes go blank if I mess around with the cellular settings. Any information is welcome! Just ask if you need more information.
  Reply
#2
I also have a similar issue like M.A. that actually started Saturday 2nd April. An exclamation mark sometimes appears but as of Saturday I noticed that my outgoing text's do not transmit. However after some testing I realised that during a phone call I can text out. regardless I receive text with no problem. I'm guessing that an update has been done and another update may be required to fix this?
  Reply
#3
Probably means you have no data connection: do you have data enabled with a valid APN?
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.19 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edition daily driver, Tow-boot on SPI, Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, Tow-boot with Arch/Phosh on eMMC
  Reply
#4
(04-06-2022, 02:08 PM)dukla2000 Wrote: Probably means you have no data connection: do you have data enabled with a valid APN?

Thankyou for responding .. I use Arch Linux on a Pinephone Convergence. It has worked perfectly well for many months as daily driver and then suddenly on Saturday an exclamation mark appears on cellular banner. I use 3G, 4G preferred, mobile data on, mobile roam data on, my provider clearly listed as Freedom. I can receive text, make calls, receive calls but I can't send text. However if I make a call to anyone I can send text to anyone but only during an active call. This occurred after doing a couple of updates on Saturday (?) I have two valid access point names.
What do you think?
  Reply
#5
Two thoughts:
1) When you make a call are you using VOIP on 4G? (The 4G symbol will remain on.) Or do you swap to 3G? I suspect you may well drop to 3G - which could explain why your SMS go when your phone is "forced" to 3G (IIRC calls are not possible on 4G itself, only via 4G data as VOIP)
2) Do you have MMS parameters setup (Chats, preferences)? Normally shouldn't make any difference to SMS but if the other party has a crapple they have a habit of sending texts as MMS rather than SMS (at least folks I know do) and so a response goes as MMS unless I am careful.
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.19 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edition daily driver, Tow-boot on SPI, Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, Tow-boot with Arch/Phosh on eMMC
  Reply
#6
(04-06-2022, 03:38 PM)dukla2000 Wrote: Two thoughts:
1) When you make a call are you using VOIP on 4G? (The 4G symbol will remain on.) Or do you swap to 3G? I suspect you may well drop to 3G - which could explain why your SMS go when your phone is "forced" to 3G (IIRC calls are not possible on 4G itself, only via 4G data as VOIP)
2) Do you have MMS parameters setup (Chats, preferences)? Normally shouldn't make any difference to SMS but if the other party has a crapple they have a habit of sending texts as MMS rather than SMS (at least folks I know do) and so a response goes as MMS unless I am careful.

When making a call I am using sim card carrier signal not VOIP. My sim usually defaults to 3G all the time but on occasion when booting phone up it will initially indicate 4G and then change after a few minutes to 3G. I have checked out Chatty and preferences and MMSC carrier settings states http://mms.invalid and APN states apn.invalid .... is this what you were talking about before? I have never touched these settings before.
  Reply
#7
The VOIP in this case would be VoLTE (Voice over LTE) which is still provided by the carrier.
  Reply
#8
(04-07-2022, 05:23 AM)wibble Wrote: The VOIP in this case would be VoLTE (Voice over LTE) which is still provided by the carrier.

I suspect at this time this problem was due to an update where there were three updates on one Saturday. The problem I believe is between 'Calls' and 'Chatty'. Calls appears to have changed something that over rules Chatty. This is why the only way I can send a text is to first make a call and during any call I can text. The exclamation mark on the top banner and the text problem started Saturday. In my opinion it's too obvious that the problem occurs suddenly at that time. I have had my PP Convergence for over 6 months now with no issue. With regards to you point about VOIP it is not setup on my device. I have since changed the band to 2G 3G preferred. So far no exclamation mark has appeared since that change yesterday however still cant send text but only receive text.
  Reply
#9
Thanks to wibble and Dukla2000 for your help. I reviewed the settings that Dukla2000 suggested and figured that out and now my text fully returned. I also apparently had to change some other settings with network as well (????).
It's strange that this would suddenly occur and a new requirement needed.
Thanks folks.
  Reply
#10
I'll test if I have the same problems that Chief had, just to make sure that changing the MMS settings is needed.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Latest update broke my cellular 112113101098101077 1 1,568 05-05-2021, 06:41 AM
Last Post: 112113101098101077

Forum Jump:


Users browsing this thread: 1 Guest(s)