Ethernet Issues on DietPi
Armbian install by way of Diet Pi.

I was really looking forward to moving our self-hosted services to a more capable SBC.  I need a solid ethernet connection that the H64b doesn't seem to want to provide.  I'm going to check with Manjaro build, but arch isn't my flavour and I'm not looking to manage a single non-debian based distro.

Am I sending this thing back to Pine?  What was the purpose of the h64 if it's barely supported by anything?

you can try Armbian , the ethernet should work here.

Also known as gamiee
Ethernet on Manjaro does work (just trying to save you the hassle). I share your frustrations on the H64, though, I have given up using it for awhile until kernel development is more mature.
Tried Manjaro Arm and it worked.  That just tells me I need to work Armbian harder for a solution.  It works during boot and provides a nts timesync before getting:

dwmac-sun8i 5020000.ethernet eth0 is down

around the 35s mark.  (not an actual copy from the log.)
Root of the problem was the Armbian build diet-pi 6.29 was based off. Rebasing their 6.33 image on a newer Buster seemed to fix the ethernet issue when I tested it.
I'm having the same problem with ETH0 as well as HDMI.

I believe, it's related to ATF is enabling regulators.

The fix is to downgrade ATF


[    8.898813] dwmac-sun8i 5020000.ethernet: PTP uses main clock
[    9.011232] dwmac-sun8i 5020000.ethernet: Current syscon value is not the default 58000 (expect 0)
[    9.025089] dwmac-sun8i 5020000.ethernet: No HW DMA feature register supported
[    9.032514] dwmac-sun8i 5020000.ethernet: RX Checksum Offload Engine supported
[    9.039841] dwmac-sun8i 5020000.ethernet: COE Type 2
[    9.044887] dwmac-sun8i 5020000.ethernet: TX Checksum insertion supported
[    9.051724] dwmac-sun8i 5020000.ethernet: Normal descriptors
[    9.057399] dwmac-sun8i 5020000.ethernet: Chain mode enabled
[    9.063272] libphy: stmmac: probed
[    9.066933] mdio_bus stmmac-0: MDIO device at address 1 is missing.
[  14.803370] dwmac-sun8i 5020000.ethernet eth0: Could not attach to PHY
[  14.810256] dwmac-sun8i 5020000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19)

Possibly Related Threads…
Thread Author Replies Views Last Post
  Armbian: Ethernet port goes down shortly after successful configuration. Kawayuppie 1 2,788 04-16-2021, 05:41 AM
Last Post: evilbunny
  DietPi OS for PINE H64 MichaIng 0 6,639 12-16-2020, 07:22 AM
Last Post: MichaIng

Forum Jump:

Users browsing this thread: 1 Guest(s)