Images for BH?
#1
Any updates on a usable test image for Maemo Lest on the BH?

Thanks.
  Reply
#2
Maemo Leste 1.0

https://maedevu.maemo.org/images/pinephone/20200223/

https://leste.maemo.org/PinePhone
  Reply
#3
(02-24-2020, 07:17 AM)canadien666 Wrote: Maemo Leste 1.0

https://maedevu.maemo.org/images/pinephone/20200223/

https://leste.maemo.org/PinePhone

Thanks for the links and many thanks to the developers of maemo leste.
It works!

When I try to use it with usb c power cable plugged, it said something like "using more power than charging". I remember something similar in other posts, is that maemo leste won't charge when system is on with usb power cable plugged?
  Reply
#4
(02-25-2020, 07:26 AM)pinetester Wrote:
(02-24-2020, 07:17 AM)canadien666 Wrote: Maemo Leste 1.0

https://maedevu.maemo.org/images/pinephone/20200223/

https://leste.maemo.org/PinePhone

Thanks for the links and many thanks to the developers of maemo leste.
It works!

When I try to use it with usb c power cable plugged, it said something like "using more power than charging". I remember something similar in other posts, is that maemo leste won't charge when system is on with usb power cable plugged?


I got that same error message when my phone was fully charged.
  Reply
#5
(02-25-2020, 07:33 AM)canadien666 Wrote:
(02-25-2020, 07:26 AM)pinetester Wrote:
(02-24-2020, 07:17 AM)canadien666 Wrote: Maemo Leste 1.0

https://maedevu.maemo.org/images/pinephone/20200223/

https://leste.maemo.org/PinePhone

Thanks for the links and many thanks to the developers of maemo leste.
It works!

When I try to use it with usb c power cable plugged, it said something like "using more power than charging". I remember something similar in other posts, is that maemo leste won't charge when system is on with usb power cable plugged?


I got that same error message when my phone was fully charged.
Another issue with wifi, I cannot power it up without black screen if wifi kill switch set to on (i.e. turn on wifi, it boots and then screen turns black, I can do nothing but to turn off phone then reset wifi kill switch to off). Dunno if it is power issue or something. I had already charged the phone to somewhere 40% based on the icon, but the indicator may be wrong. I may need to charge it more the test it.

If wifi kill swtich is set to off (wifi off, actually all kill switches are off) the syslog indeed said "Could not read interface wlan0 flags: No such device" and runs normally.

At https://leste.maemo.org/PinePhone
it said wifi works but also "Wireless Yes Involves installing out of tree driver ".
Should wifi work out of the box or I have to install something manually?

P.S. Just double checked if all kill switches are set to on it won't boot even if usb cable is plugged in. Is that not enough battery power?
  Reply
#6
(02-25-2020, 09:23 AM)pinetester Wrote:
(02-25-2020, 07:33 AM)canadien666 Wrote:
(02-25-2020, 07:26 AM)pinetester Wrote:
(02-24-2020, 07:17 AM)canadien666 Wrote: Maemo Leste 1.0

https://maedevu.maemo.org/images/pinephone/20200223/

https://leste.maemo.org/PinePhone

Thanks for the links and many thanks to the developers of maemo leste.
It works!

When I try to use it with usb c power cable plugged, it said something like "using more power than charging". I remember something similar in other posts, is that maemo leste won't charge when system is on with usb power cable plugged?


I got that same error message when my phone was fully charged.
Another issue with wifi, I cannot power it up without black screen if wifi kill switch set to on (i.e. turn on wifi, it boots and then screen turns black, I can do nothing but to turn off phone then reset wifi kill switch to off). Dunno if it is power issue or something. I had already charged the phone to somewhere 40% based on the icon, but the indicator may be wrong. I may need to charge it more the test it.

If wifi kill swtich is set to off (wifi off, actually all kill switches are off) the syslog indeed said "Could not read interface wlan0 flags: No such device" and runs normally.

At https://leste.maemo.org/PinePhone
it said wifi works but also "Wireless Yes Involves installing out of tree driver ".
Should wifi work out of the box or I have to install something manually?

P.S. Just double checked if all kill switches are set to on it won't boot even if usb cable is plugged in. Is that not enough battery power?

Wifi for me worked OOTB with Maemo Leste.  I was able to login at home via a single router and with the "mesh system" at work.  The system remembers both connections and automatically connects to them. I really didn't make any WLAN changes or play with the kill switches.

I'm really impressed with the Wifi running with Maemo Leste so far.  I also had a good Wifi experience using SFOS on my BraveHeart. 

UT wifi seems to only work well with a single router/access point. UT was VERY buggy with the mesh network at my job.  Didn't play around much with PMOS/Manjaro...  Not a fan of Plasma Mobile or PHOSH...
  Reply
#7
Finally I tried once with WiFi working but not with virtual keyboard at the same time.

I dd the card again with full battery with kill switch setting only wifi on, it worked with wifi that can scan for netowrk, but virtual keyboard won't appear even I changed in setting.

Then I turned off phone, set kill switch to off then restarted, virtual keyboard worked in console. I changed some of the settings like to have 1 view ony instead of 4, reversed console fonts color (I can't remember all of them). Then turned off phone, set kill switch to wifi on, reboot and then black screen again.

So it might have something to do with my setting of the phone and the kill switch combination. Anyway I will check the syslog later.
  Reply
#8
(02-26-2020, 10:25 AM)pinetester Wrote: Finally I tried once with WiFi working but not with virtual keyboard at the same time.

I dd the card again with full battery with kill switch setting only wifi on, it worked with wifi that can scan for netowrk, but virtual keyboard won't appear even I changed in setting.

Then I turned off phone, set kill switch to off then restarted, virtual keyboard worked in console. I changed some of the settings like to have 1 view ony instead of 4, reversed console fonts color (I can't remember all of them). Then turned off phone, set kill switch to wifi on, reboot and then black screen again.

So it might have something to do with my setting of the phone and the kill switch combination. Anyway I will check the syslog later.

I figured out what setting at last! It was the brightness setting. After I set the brightness to maximum it is ok to start with WiFi kill switch, otherwise it will be black screen. However with WiFi kill switch set to off brightness setting is ok to set to minimum.

Can someone also try it and confirm it is not only me? If yes perhaps tell the developer.
  Reply
#9
Most feedback is occurring on their website and IRC, there is an ongoing thread the devs are watching at https://talk.maemo.org/showthread.php?p=1565822
*.*.* PinePhone BraveHeart edition w/ distro: Debian + Phosh // GuixOS, Debian, Arch // pocket linux enthusiast // washed up sysadmin *.*.*
  Reply
#10
FYI, there is a new Maemo Leste image posted today. No changelog yet, but Devuan has been updated to Beowulf.

http://maedevu.maemo.org/images/pinephone/20200323/
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)