Is some u-boot required on the SPI for installing debian with the official installer?
#1
Hi,

https://wiki.pine64.org/wiki/ROCKPro64_Software_Release reports the possibility of installing debian on the ROCKPro64 using the Official Debian Installer via the installer image to be found at https://deb.debian.org/debian/dists/bull...rd-images/

I have verified that the installer image boots and does its job of downloading and installing stuff.  However, installing (at least installing on the EMMC) delivers a system incapable of booting.

I now wonder if this is because the official debian installer does not install a bootloader and expects a bootloader to be already present on the SPI.

If this is the case, the page at https://wiki.pine64.org/wiki/ROCKPro64_Software_Release shouild probably say so.

I have tried to install tow-boot on the SPI expecting it to be the best option for a general bootloader.  Unfortunately, It does not appear to work. After coming up, it hangs at

Code:
Booting using the fdt blob at 0x1f00000

It is unclear to me if this is a bug in tow-boot (also looking at https://github.com/Tow-Boot/Tow-Boot/issues/186).

If it is, what would be an appropriate uboot for running debian?
  Reply
#2
Hi,

i had exactly the same problem you describe. Following the guide at https://github.com/sigmaris/u-boot/wiki/...oot-to-SPI with the SPI Image from https://github.com/sigmaris/u-boot/relea...spi.img.gz worked for me. It seems that the wiki should be updated, that updating the spi might help to resolve boot problems.

I hope updating the SPI to that version helps you too. I didn't need to reinstall debian to my emmc, it just worked after inserting it back after updating the SPI.

best wishes
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Install Mali 400 Drivers for Debian 11 on RockPro64 MaverickPi 2 1,242 02-19-2022, 06:44 AM
Last Post: sigmaris
  Installing Ubuntu Server on RockPro64 deutschlmao 1 1,169 02-15-2022, 08:44 AM
Last Post: Rocklobster
  Debian image configured for USB-C OTG? djonathan 2 1,362 01-06-2022, 03:09 AM
Last Post: susy1075
  How I Got Fedora Linux to Boot From eMMC (or microSD, for that matter) whitecat23 4 1,994 01-03-2022, 10:32 AM
Last Post: whitecat23
Bug Unreliable display in Armbian and Debian ksattic 3 1,903 11-17-2021, 05:42 AM
Last Post: PakoSt
  Debian Bullseye & RockPro64: No tty consoles? Pete Tandy 9 4,416 11-08-2021, 02:33 PM
Last Post: TRS-80
  Vanilla mainline Debian 11 (Bullseye) on the RockPro64 Pete Tandy 21 9,387 11-06-2021, 06:42 AM
Last Post: Pete Tandy
  HBA Card working on Aufan's builds but not in debian, armbian or dietpi charsi 1 1,109 10-29-2021, 11:15 AM
Last Post: TRS-80
  Two Questions About Debian on RockPro64 publiclewdness 0 852 09-30-2021, 11:54 AM
Last Post: publiclewdness
  Overlays not loading at boot - ROCKPRO64 on Armbian rookieone 0 814 09-28-2021, 04:10 AM
Last Post: rookieone

Forum Jump:


Users browsing this thread: 1 Guest(s)