Is SPI Working?
#43
With the latest Armbian, /dev/spidevX.X are enabled using overlay. Simply add "overlays=sun8i-h3-spi0-spidev" into /boot/armbianEnv.txt.

And to test if it is actually working, there a piece of code on the net which is named "spidev_test.c" to test loopback of MOSI/MISO.

Example :
Code:
./spidev_test -D /dev/spidev1.0
spi mode: 0
bits per word: 8
max speed: 500000 Hz (500 KHz)

FF FF FF FF FF FF
40 00 00 00 00 95
FF FF FF FF FF FF
FF FF FF FF FF FF
FF FF FF FF FF FF
DE AD BE EF BA AD
F0 0D
  Reply


Messages In This Thread
Is SPI Working? - by ericnhitterdal@gmail.com - 06-08-2016, 09:54 AM
RE: Is SPI Working? - by longsleep - 06-08-2016, 01:49 PM
RE: Is SPI Working? - by ericnhitterdal@gmail.com - 06-08-2016, 02:40 PM
RE: Is SPI Working? - by alevecchio - 07-16-2016, 03:01 PM
RE: Is SPI Working? - by martinayotte - 06-08-2016, 02:51 PM
RE: Is SPI Working? - by ericnhitterdal@gmail.com - 06-09-2016, 07:21 AM
RE: Is SPI Working? - by alevecchio - 07-16-2016, 08:51 PM
RE: Is SPI Working? - by martinayotte - 07-17-2016, 07:38 AM
RE: Is SPI Working? - by alevecchio - 07-17-2016, 09:50 AM
RE: Is SPI Working? - by martinayotte - 07-17-2016, 10:28 AM
RE: Is SPI Working? - by ericnhitterdal@gmail.com - 07-18-2016, 07:23 AM
RE: Is SPI Working? - by longsleep - 07-17-2016, 12:05 PM
RE: Is SPI Working? - by martinayotte - 07-17-2016, 02:34 PM
RE: Is SPI Working? - by martinayotte - 07-18-2016, 08:44 PM
RE: Is SPI Working? - by xalius - 07-17-2016, 12:30 PM
RE: Is SPI Working? - by longsleep - 07-17-2016, 01:04 PM
RE: Is SPI Working? - by martinayotte - 07-18-2016, 07:36 AM
RE: Is SPI Working? - by ericnhitterdal@gmail.com - 07-18-2016, 07:54 AM
RE: Is SPI Working? - by alevecchio - 07-18-2016, 09:35 PM
RE: Is SPI Working? - by adamw - 07-19-2016, 06:37 AM
RE: Is SPI Working? - by martinayotte - 07-19-2016, 08:15 AM
RE: Is SPI Working? - by alevecchio - 07-19-2016, 09:55 AM
RE: Is SPI Working? - by martinayotte - 07-19-2016, 11:51 AM
RE: Is SPI Working? - by ericnhitterdal@gmail.com - 07-19-2016, 01:15 PM
RE: Is SPI Working? - by martinayotte - 07-19-2016, 01:56 PM
RE: Is SPI Working? - by alevecchio - 07-19-2016, 06:42 PM
RE: Is SPI Working? - by martinayotte - 07-19-2016, 07:48 PM
RE: Is SPI Working? - by alevecchio - 07-20-2016, 07:13 PM
RE: Is SPI Working? - by martinayotte - 07-21-2016, 08:46 AM
RE: Is SPI Working? - by alevecchio - 07-21-2016, 11:59 AM
RE: Is SPI Working? - by martinayotte - 07-22-2016, 08:49 AM
RE: Is SPI Working? - by alevecchio - 07-30-2016, 08:04 PM
RE: Is SPI Working? - by alevecchio - 08-01-2016, 01:46 PM
RE: Is SPI Working? - by martinayotte - 08-01-2016, 03:26 PM
RE: Is SPI Working? - by alevecchio - 08-01-2016, 06:18 PM
RE: Is SPI Working? - by martinayotte - 08-02-2016, 10:11 AM
RE: Is SPI Working? - by longsleep - 08-02-2016, 12:13 PM
RE: Is SPI Working? - by MarkHaysHarris777 - 08-02-2016, 12:52 PM
RE: Is SPI Working? - by ericnhitterdal@gmail.com - 10-19-2016, 01:18 PM
RE: Is SPI Working? - by milekium - 02-23-2017, 03:36 PM
RE: Is SPI Working? - by MarkHaysHarris777 - 02-23-2017, 04:08 PM
RE: Is SPI Working? - by milekium - 02-24-2017, 06:25 AM
RE: Is SPI Working? - by martinayotte - 02-24-2017, 09:08 AM
RE: Is SPI Working? - by milekium - 02-24-2017, 09:42 AM
RE: Is SPI Working? - by xalius - 02-24-2017, 10:19 AM
RE: Is SPI Working? - by x893 - 04-05-2017, 02:52 PM
RE: Is SPI Working? - by xalius - 04-05-2017, 03:13 PM
RE: Is SPI Working? - by x893 - 04-05-2017, 03:24 PM
RE: Is SPI Working? - by xalius - 04-05-2017, 04:37 PM
RE: Is SPI Working? - by x893 - 04-05-2017, 04:45 PM
RE: Is SPI Working? - by xalius - 04-05-2017, 04:51 PM
RE: Is SPI Working? - by x893 - 04-05-2017, 07:46 PM
RE: Is SPI Working? - by martinayotte - 04-06-2017, 08:04 AM
RE: Is SPI Working? - by x893 - 04-06-2017, 12:36 PM
RE: Is SPI Working? - by martinayotte - 04-06-2017, 03:46 PM
RE: Is SPI Working? - by x893 - 04-10-2017, 02:45 AM
RE: Is SPI Working? - by x893 - 04-10-2017, 02:23 PM
RE: Is SPI Working? - by martinayotte - 04-12-2017, 10:06 AM
RE: Is SPI Working? - by x893 - 04-14-2017, 03:03 PM
RE: Is SPI Working? - by louwie17 - 07-28-2017, 09:46 PM
RE: Is SPI Working? - by pfeerick - 07-29-2017, 08:39 PM
RE: Is SPI Working? - by louwie17 - 07-30-2017, 05:56 AM
RE: Is SPI Working? - by pfeerick - 07-30-2017, 06:26 PM
RE: Is SPI Working? - by louwie17 - 07-31-2017, 07:39 AM
RE: Is SPI Working? - by louwie17 - 08-12-2017, 03:14 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  touch screen not working mike280z 1 2,844 12-22-2016, 12:46 PM
Last Post: Bluphire
  RaZberry Module (z-wave) need support to get it working! Luxus 13 14,193 11-03-2016, 02:04 AM
Last Post: Luxus

Forum Jump:


Users browsing this thread: 5 Guest(s)