HDMI doesn't work on rock64 - Printable Version

+- PINE64 (
+-- Forum: ROCK64 (
+--- Forum: Linux on Rock64 (
+--- Thread: HDMI doesn't work on rock64 (/showthread.php?tid=8575)

HDMI doesn't work on rock64 - rock7 - 12-16-2019

HDMI doesn't work with any Kernel except the Kernel 4.4 from Rockchip (it also doesn't work with xorg) i tried out all kernel configs from rockchip and ayufan always same error:
[    4.030085] printk: console [ttyS2] enabled
[    4.031672] rockchip-vop ff370000.vop: Adding to iommu group 1
[    4.038101] rockchip-drm display-subsystem: bound ff370000.vop (ops 0xffffffc0108c27d8)
[    4.038924] rockchip-drm display-subsystem: failed to bind ff3c0000.hdmi (ops 0xffffffc0108c5f30): -517
[    4.040292] rockchip-drm display-subsystem: master bind failed: -517

With Kernel 4.4 from Rockchip (ayufan) HDMI works:
[    3.167892] [drm] Initialized drm 1.1.0 20060810
[    3.173651] [drm] Rockchip DRM driver version: v1.0.1
[    3.174380] rockchip-drm display-subsystem: devfreq is not set
[    3.175647] rockchip-drm display-subsystem: bound ff370000.vop (ops 0xffffff8008d86950)
[    3.176798] i2c i2c-4: of_i2c: modalias failure on /hdmi@ff3c0000/ports
[    3.177487] dwhdmi-rockchip ff3c0000.hdmi: registered DesignWare HDMI I2C bus driver
[    3.178358] dwhdmi-rockchip ff3c0000.hdmi: Detected HDMI TX controller v2.11a with HDCP (inno_dw_hdmi_phy2)
[    3.180400] rockchip-drm display-subsystem: bound ff3c0000.hdmi (ops 0xffffff8008d7afa8)
[    3.181186] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    3.181851] [drm] No driver support for vblank timestamp query.
[    3.182495] rockchip-drm display-subsystem: failed to parse display resources
[    3.402118] rockchip-vop ff370000.vop: [drm:vop_crtc_enable] Update mode to 1280x1024p60, type: 11
[    3.469911] Console: switching to colour frame buffer device 160x64
[    3.503468] rockchip-drm display-subsystem: fb0:  frame buffer device

X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.14.89-0-vanilla aarch64 Alpine Linux
Current Operating System: Linux localhost 5.4.2 #1 SMP Thu Dec 12 03:04:42 CET 2019 aarch64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.4.2 modules=loop,squashfs,sd-mod,usb-storage modloop=/boot/modloop-5.4.2 extra_latent_entropy1
Build Date: 31 May 2019  06:21:31AM
Current version of pixman: 0.38.4
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan 21 10:28:08 2016
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
MESA-LOADER: failed to open rockchip (search paths /usr/lib/xorg/modules/dri)
failed to load driver: rockchip
MESA-LOADER: failed to open kms_swrast (search paths /usr/lib/xorg/modules/dri)
failed to load driver: kms_swrast
MESA-LOADER: failed to open swrast (search paths /usr/lib/xorg/modules/dri)
failed to load swrast driver
couldn't get display device
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Unsupported high keycode 372 for name <I372> ignored
>                   X11 cannot support keycodes above 255.
>                   This warning only shows for the first high keycode.
> Internal error:   Could not resolve keysym XF86MonBrightnessCycle
> Internal error:   Could not resolve keysym XF86RotationLockToggle
Errors from xkbcomp are not fatal to the X server
(EE) /usr/share/libinput: failed to find data files
(EE) Failed to load the device quirks from /usr/share/libinput and /etc/libinput/local-overrides.quirks. This will negatively affect device b.
/usr/bin/startxfce4: X server already running on display :0
<stdin>:0: warning: Unknown encoding: C.UTF-8
    xfce4-session: No GPG agent found
xfce4-session: No SSH authentication agent found

(xfce4-session:2231): xfce4-session-WARNING **: 10:28:10.365: xfsm_manager_load_session: Something wrong with /home/admin/.cache/sessions/xfc?

(xfwm4:2278): GLib-CRITICAL **: 10:28:19.096: g_str_has_prefix: assertion 'prefix != NULL' failed

(xfsettingsd:2284): GLib-CRITICAL **: 10:28:20.459: g_str_has_prefix: assertion 'prefix != NULL' failed

(xfsettingsd:2284): GLib-GObject-CRITICAL **: 10:28:20.721: g_value_get_string: assertion 'G_VALUE_HOLDS_STRING (value)' failed

(xfsettingsd:2284): GLib-GObject-CRITICAL **: 10:28:20.800: g_value_get_string: assertion 'G_VALUE_HOLDS_STRING (value)' failed
Error relocating /usr/bin/Thunar: pango_attr_insert_hyphens_new: symbol not found
xfsettingsd: No window manager registered on screen 0.
xfce4-panel: No window manager registered on screen 0. To start the panel without this check, run with --disable-wm-check.
No window manager registered on screen 0. To start the xfdesktop without this check, run with --disable-wm-check.
xfce4-panel-Message: 10:28:33.334: Plugin "statusnotifier-7" was not found and has been removed from the configuration
xfce4-panel-Message: 10:28:33.338: Plugin "pulseaudio-8" was not found and has been removed from the configuration
xfce4-panel-Message: 10:28:33.377: Plugin "notification-plugin-10" was not found and has been removed from the configuration

** (wrapper-2.0:2315): WARNING **: 10:28:36.247: No outputs have backlight property

(wrapper-2.0:2315): xfce4-power-manager-plugin-WARNING **: 10:28:36.920: Xfce4-power-manager: The panel plugin is present, so the tray icon g.

(wrapper-2.0:2315): Gtk-WARNING **: 10:28:37.092: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button,)

(xfdesktop:2311): GLib-GObject-CRITICAL **: 10:28:46.065: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
^Cxinit: connection to X server lost

waiting for X server to shut down ^VGdk-Message: 10:28:59.978: xfdesktop: Fatal IO error 38 (Function not implemented) on X server :0.

Gdk-Message: 10:28:59.978: xfsettingsd: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

I boot with extlinux.conf: The kernel starts only without console bootparameter: When i insert console=tty0 as boot paramter the kernel dont start.

Does anyone know what the problem could be.
Thank you in advance for your help