RockPro64 and 802.1q support [Solved] - Printable Version

+- PINE64 (
+-- Forum: ROCKPRO64 (
+--- Forum: Linux on RockPro64 (
+--- Thread: RockPro64 and 802.1q support [Solved] (/showthread.php?tid=6704)

RockPro64 and 802.1q support [Solved] - divek - 10-25-2018

Hi everyone, 

In last week rockpro has been landed on my desk. I installed ubuntu minimal using the `pine64 Installer` which was describe in the official Resource tab. 

I've tried to setup network, but it's immpossible for my home, as I don't see 8021q module for the kernel. It can not be loaded, as it's not compiled. 

Could you tell me, if there is any other unofficial image, where the 8021q.ko is already buildin in the image? Specially with the userspace delivered with ubuntu?

If not, what is the problem of the rockpro64 kernel, that 802.1q is not supported? 

Thanks for any tip


RE: RockPro64 and 802.1q support - Ross - 10-27-2018

I receive also my RockPro last week and start to configure it.
I need also VLAN's for my settings.

I have installed the "Ubuntu 18.04 Minimal aarch64" from ayufan's with Etcher (which is new to me as I work usualy with Centos).

I am abble to setup VLAN by editing /etc/netplan/eth0.yaml (and use netplan)
It works for me as expected (no IP on the main eth0 but only on the eth0.xx interface).

Hope this can help you.


RE: RockPro64 and 802.1q support - divek - 11-04-2018

Hi Ross,

thank you a lot for tip. Yes, you are right, that if I try to use netplan for the configuration of vlans then everything is working as you wrote.

Thanks, problem is solved now