Cant get rockpro64 working - Printable Version

+- PINE64 (
+-- Forum: ROCKPRO64 (
+--- Forum: General Discussion on ROCKPRO64 (
+--- Thread: Cant get rockpro64 working (/showthread.php?tid=17887)

Cant get rockpro64 working - brasilikum - 02-04-2023

Hi everybody,

i have 2 RockPro64 and both behave strange.
I have a hdmi cable, keyboard and a ethernet cable connected. 

The first rockpro64 i was trying to uses crashes a few secounds after the uboot screen. I tried Armbian and Debian and pretty much same behaviour. 

After a few hours of trying the first board i was desperate and wondered if the board is simple broken and tryed the secound board i bought...
and it actually immediatly worked! I could boot the armbian version i previously was unable to boot with the first board! I created a user and logged in from remote via ssh. But now i see i cant use 'shutdown now' and then press the boot button or reset button. I need to reconnect the power for the board to reboot.
So i have 2 questions. 

1. How can i fix the first board? It starts with the uboot screen boots linux but after a few secounds crashes. The screen goes idle and the power led is the only led on the board left on. (even the ethernet led is turned off)

2. What are the reset and boot buttons good for?

RE: Cant get rockpro64 working - diizzy - 03-01-2023

Are you sure that you have a reliable and working SD card? Do you have a proper PSU (min 3A that ha some weight to it)? I've had mixed results with various Armbian images in general but does the same occur if you try lets say Manjaro?

2. These are hardware buttons connected to the SoC afaik, reset not going to work the same as if you're using a x86 PC. I dont know offhand what the boot toggles.

RE: Cant get rockpro64 working - dukla2000 - 03-03-2023

(02-04-2023, 02:43 PM)brasilikum Wrote: ...
2. What are the reset and boot buttons good for?

Mine work as per the wiki.

RE: Cant get rockpro64 working - runyor - 03-19-2023

I am having the same issue, might be related to:
Not sure if this is your case since you are getting different results on two boards.

Here is a recording of the failing boot sequence:

Manjaro worked great and now I am waiting for a Serial adapter for Debian installation.