LED not working on 3GB variant - Printable Version

+- PINE64 (
+-- Forum: PinePhone (
+--- Forum: PinePhone Hardware (
+--- Thread: LED not working on 3GB variant (/showthread.php?tid=14688)

LED not working on 3GB variant - IVp - 08-18-2021


I remember that in January to be surprised that the led did absolutely nothing when booting up after replacing the board from an UBports version to the 3GB replacement version. I even thought that I broke the board all together because without a boot image and with no led feedback there is no visible difference between a dead phone and a phone that is perfectly fine but has not boot image. 
Since everything else worked fine in different images, I assumed some minor differences between the board revisions were to blame for lack of feedback from the led. 
Now, I tried to find out what is going on and I can not find the culprit. I never got anything out of the sxmo led scripts, but now I installed the factorytest v0.64.0 and still nothing when I press [RGB Led]. 

Is the led broken? Did I do something wrong during installation?


RE: LED not working on 3GB variant - 8bit - 08-18-2021

The LED is a common cathode unit. The R/G/B elements are each connected between a GPIO pin and ground.
Page 11

All the different OS I've tried at least blink the LED in some color during boot. The factory test image will also cycle through the colors.
Since you don't get any output, the LED is probably damaged or missing.

The LED is the tiny white SMT device to the left of the headphone jack and proximity sensor.

RE: LED not working on 3GB variant - IVp - 08-21-2021

Thank you. I'll accept that the led is broken. I guess this is a rare issue. Sadly I don't have the tools or skills to solder something that small.