PINE64
phone call using built it app will not go to bluetooth - Printable Version

+- PINE64 (https://forum.pine64.org)
+-- Forum: PinePhone (https://forum.pine64.org/forumdisplay.php?fid=120)
+--- Forum: PinePhone Software (https://forum.pine64.org/forumdisplay.php?fid=121)
+---- Forum: Debian on PinePhone (https://forum.pine64.org/forumdisplay.php?fid=139)
+---- Thread: phone call using built it app will not go to bluetooth (/showthread.php?tid=14222)



phone call using built it app will not go to bluetooth - motox6 - 06-18-2021

I was listening to a podcast via a bluetooth headset.

I paused the podcast app and dialed a number using the standard phone app.

It would not connect the audio to the the bluetooth headset.

It was stuck using the phone speaker.  I toggled between speakerphone mode and hold the phone up to your ear mode.  But no bluetooth.

Is there supposed to be a bluetooth button somewhere?

After I gave up on the call, I went back to the podcast app and the bluetooth worked as expected.


RE: phone call using built it app will not go to bluetooth - wibble - 06-22-2021

There isn't yet an audio profile to do the routing between the bluetooth and the modem. Someone in another thread reported at least partial success using a script to make the mixer changes and route the audio between devices.


RE: phone call using built it app will not go to bluetooth - Gribouille - 06-28-2021

Hello,

I'm looking for a way to share my phone with the Bluetooth too. In my case, my vehicle can make the relay between the phone and a Bluettoth headset. But I can only find an option to share some files on Mobian with the native applications.

An idea ?

Thanks


RE: phone call using built it app will not go to bluetooth - wibble - 06-28-2021

Here's the bug report - no sign that anyone is working on it yet.
https://gitlab.com/mobian1/callaudiod/-/issues/12

Start reading at this post for a script that reportedly does the job, at least as proof of concept. Later posts cover dropping the latency to something usable.
https://forum.pine64.org/showthread.php?tid=14055&pid=96379#pid96379