megapixels - Printable Version

+- PINE64 (
+-- Forum: PinePhone (
+--- Forum: General Discussion on PinePhone (
+--- Thread: megapixels (/showthread.php?tid=13508)

Pages: 1 2

megapixels - rvh - 03-27-2021

can someone tell me how to unintall and reinstall megapixels in terminal? using mobian

RE: megapixels - lsitongia - 03-27-2021

On my Mobian PinePhone, I see it listed as installed in the Software app, with a button to remove it. I haven't tried. Have you tried that and it fails in some way? I haven't tried installing it using the Software app, but it is listed as available. So, you should use the Software app to uninstall and reinstall it.

RE: megapixels - bitsandnumbers - 03-27-2021

In terminal :

(remove app + config with --purge)
sudo apt remove --purge megapixels

(remove leftover dependencies)
sudo apt autoremove

sudo apt install megapixels

or a oneliner just to remove and reinstall megapixels (you keep config and dependencies are not removed nor reinstalled - ie: they stay in place)
sudo apt-get -y remove megapixels && sudo apt-get -y install megapixels

RE: megapixels - rvh - 03-28-2021

if your a tech moron like myself and you decide to uninstall megapixels to see if a reinstall will get it working, dont do it. if you do you will need the excellent advise given above by bitsandnumbers. thanks by the way. i dont know if its just me or all mobian users, but the camera on my phone has never worked. when i loaded megapixels i got a blank screen and now it wont even open. is it just to early for the camera to work or is there something i can do to get it working?

RE: megapixels - bitsandnumbers - 03-28-2021

I've got not advice to help you make the camera to work (though I know I've seen your issue discussed before), but the camera is actually supposed to work - not *very* well right now, but it's getting there and post processed pictures are pretty decent.

RE: megapixels - dukla2000 - 03-28-2021

(03-28-2021, 08:52 AM)rvh Wrote: ...
i dont know if its just me or all mobian users, but the camera on my phone has never worked.

In general it is working as well as can be expected at the moment for a basic sensor. Are you sure you haven't got it disabled on the DIP switches?

Otherwise check what you have in the systemlog: I have a 5.11 kernel but you should have something like 

[   16.973553] videodev: Linux video capture interface: v2.00
[   17.152422] sun8i-rotate 1020000.rotate: Device registered as /dev/video0
[   17.172874] cedrus Device registered as /dev/video1
[   17.384239] sun8i-di 1e00000.deinterlace: Device registered as /dev/video2
from dmesg | grep video

Last, check this thread for more on the travails of megapixels and a current defect in the postprocessing.

RE: megapixels - rvh - 03-28-2021

Ok only i dont know how to get the code or how to place it here. P.S. thanks for your time.

RE: megapixels - xalius - 03-29-2021

Do you get a preview in megapixels when you start it? When you switch between front and back camera in the app, does that work?

RE: megapixels - rvh - 03-29-2021

right now, the camera wont even open.

RE: megapixels - rvh - 04-01-2021

i reinstalled megapixels and now have the back facing camera working only the pics are just vertical lines. the front facing camera wont open.