PINE64
Testing USB port(s) - Printable Version

+- PINE64 (https://forum.pine64.org)
+-- Forum: ROCK64 (https://forum.pine64.org/forumdisplay.php?fid=85)
+--- Forum: General Discussion on ROCK64 (https://forum.pine64.org/forumdisplay.php?fid=86)
+--- Thread: Testing USB port(s) (/showthread.php?tid=13393)



Testing USB port(s) - clach04 - 03-14-2021

I've been running and old ayufan rock64 build of OMV (v4) - I set it up 2020-01

I had been getting the occasional issue with the un-powered USB3 HD (only USB device plugged in) where it needed to be remounted.

About a two weeks or so ago, ssh sessions would consistently freeze when I tried to "ls" a specific directory and/or issue "df". SD access seemed.

I tried with a powered USB hub, with no change.

I had a small collection of rock64's that I picked up cheap and swapped out the board from the case (with fan) and the same SD card/OS, case, PSU, USB HD and it immediately worked fined. Its been running fine for 11 days now - with no incidents.

I suspect there is something going on with the USB ports (I'm guessing damaged).

Any suggestions on how to test the ports? Other than "df" and try accessing random directories?

I have another rock64 that I deployed with Armbian and Docker (with Pi Hole in a container) its been running solid for 4 months (NOTE this only has a USB2serial device on it) so I suspect I either got a flakey board originally or something in my environment has damaged the USB ports.

NOTE I'm planning on using Armbian for all my boards, I just haven't made the time to move OMV to Armbian+OMV5 yet.