Cannot charge and NO Wifi? - Printable Version

+- PINE64 (
+-- Forum: General (
+--- Forum: Getting Started (
+--- Thread: Cannot charge and NO Wifi? (/showthread.php?tid=10433)

Cannot charge and NO Wifi? - jiapei100 - 06-26-2020

I just received my PINE64 Community Edition: UBports Limited Edition Linux today. And it seems it got some issues:

1) It seems the power on my laptop's USB port is NOT powerful enough to power PINE64 up, PINE64 always restart after I see the PINE64 logo.
2) Therefore, I tried to power PINE64 up using USB power adaptor with the delivered Type C cable. Now, PINE64 boots into Ubuntu 16.04. However, it's NOT changing at all. the Battery Charge Level sticked to 0%, no matter how many hours I left PINE64 for charging. As long as I disconnect the Type C cable, PINE64 is out of power and shut down right away.
3) What'e even more weird. In Settings->Battery, there is even choices for Wi-Fi and Bluetooth? What's that for?
4) And in Settings->Wi-Fi, there is ONLY 1 option: Previous networks , PINE64 won't be able to show Wireless network around. 

So, in sum: PINE64 ALWAYS stick to batter charge 0%, and Wi-Fi doesn't search wireless network at all.

Did anybody have those issue as well? Is there a way to let me reflash Ubuntu onto PINE64 from scratch ?? Say, how can I flash Ubuntu 20.04 onto PINE64 ?

Thank you very much. Looking foward to have some fun on PINE64.


RE: Cannot charge and NO Wifi? - yincision - 06-26-2020


I just got my phone today and I am having the exact same issue.

RE: Cannot charge and NO Wifi? - Danct12 - 06-26-2020

You have to remove the tape from the battery contacts in order to get Wi-Fi and charging working.

Picture of tape on the battery contacts:

RE: Cannot charge and NO Wifi? - jiapei100 - 06-27-2020

Problem solved... Thank you very much... I need to remove the tape...