PINE64
brand new manjaro PBP - pacman PGP import failure - Printable Version

+- PINE64 (https://forum.pine64.org)
+-- Forum: General (https://forum.pine64.org/forumdisplay.php?fid=1)
+--- Forum: Getting Started (https://forum.pine64.org/forumdisplay.php?fid=21)
+--- Thread: brand new manjaro PBP - pacman PGP import failure (/showthread.php?tid=10314)



brand new manjaro PBP - pacman PGP import failure - shindagger - 06-18-2020

Just unboxed my new PBP, and i cannot get snapd (or any software) installed. First, generally speaking, is there a forum post for new versions of manjaro, recently shipped? Would love some kind of "getting started" doc... 

`[font=Slack-Lato, appleLogo, sans-serif]5.6.0-2-MANJARO-ARM`[/font]



when i run `sudo pacman -S snapd` it attempts to download a PGP key, and fails every time. [font=Tahoma, Verdana, Arial, sans-serif]Computer has network connectivity, can surf the web with firefox.[/font]

i've tried the following command in every possible order:
`sudo rm -r /etc/pacman.d/gnupg/`
`sudo pacman-key --init` 
`sudo pacman -Syyu`
`sudo pacman-mirrors -g`
`sudo pacman -Sy gnunpg archlinux-keyring manjaro-keyring`

polkit is active and running.

any information at all would be helpful. can't even install vim right now, and can't get any of the boot images from the wiki to work on my SD..