PINE64

Full Version: Chromium?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7
With some help from Fourdee - I got Chromium up and running on DietPI on Pine64 :

http://dietpi.com/phpbb/viewtopic.php?f=...2993#p2984

I sorta got it running on the Longsleep Debian XFCE build - but I was unable to connect to my Google account, and forget about running more than two tabs at once...

Works pretty much flawlessly following Fourdee's info at the DietPI forum... which is based mostly on stuff that's been posted in this thread... but new locations for the arm64 deb files...
Note: The linux build essentials posts from the tail of this thread have been preserved and moved to "LInux Build Essentials Research" tid=2265.

Look forward to anyone interested in continuing that discussion there; The Chromium thread may continue... carry on !

marcus
Gdebi installed ok - but come up against a dependency problemo.

Using Debian Mate image here 

- any ideas?

[email protected]:~/Downloads$ sudo gdebi chro*
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done
Building data structures... Done
This package is uninstallable
Dependency is not satisfiable: libstdc++6 (>= 5.2)
(04-25-2016, 07:29 PM)baryluk Wrote: [ -> ]I applied some of the Riku's patches and fixed one minor issue with some syscalls in the sandbox, and was able to build chromium 50.

You still need --disable-seccomp-filter-sandbox

Packages:

https://drive.google.com/folderview?id=0...aring#list

You only really need chromium_50.0.2661.75-2_arm64.deb (about 40MB).

Hello I am using Mate, after update, upgrade and dist-upgrade, I cannot install this ver50 anymore, So I install 53 instead, but the page cannot load anything at all, even the settings page, completely useless, how to fix?

(10-09-2016, 07:31 AM)victagayun Wrote: [ -> ]
(04-25-2016, 07:29 PM)baryluk Wrote: [ -> ]I applied some of the Riku's patches and fixed one minor issue with some syscalls in the sandbox, and was able to build chromium 50.

You still need --disable-seccomp-filter-sandbox

Packages:

https://drive.google.com/folderview?id=0...aring#list

You only really need chromium_50.0.2661.75-2_arm64.deb (about 40MB).

Hello I am using Mate, after update, upgrade and dist-upgrade, I cannot install this ver50 anymore, So I install 53 instead, but the page cannot load anything at all, even the settings page, completely useless, how to fix?

this one helped! 
http://forum.pine64.org/showthread.php?t...6#pid16066
(04-23-2016, 02:32 PM)baryluk Wrote: [ -> ]It works!

[Image: mpnBz7w.png]

(High CPU usage is mostly due to the fact that MATE system monitor is consuming quiet a bit of cpu for drawing stuff. When using top, chromium is using few % when idle basically)

Remember to run with:

$ chromium --disable-seccomp-filter-sandbox

(probably due to the bug in the old kernel, seccomp and seccomp filter is in 3.10.65 according to /proc/config.gz)

Packages:

http://repo.linaro.org/ubuntu/linaro-ove...m-browser/

Debian bug: https://bugs.debian.org/cgi-bin/bugrepor...799939#113

There should also be 49.0 in debian experimental, didn't checked it yet.

Hi there I'm new in this forum. I'm struggling trying to make chromium work like it should do but the procedure you describe let the browsing safety "uncovered" and, since this is the only device I've to study at the moment I'd prefer to solve the problem in different ways. I get the error with seccomp and sandbox, is there anyone that knows how could I fix it? thank you so much for your attention
(10-09-2016, 01:51 PM)Mr.Thinker Wrote: [ -> ]
(04-23-2016, 02:32 PM)baryluk Wrote: [ -> ]It works!

[Image: mpnBz7w.png]

(High CPU usage is mostly due to the fact that MATE system monitor is consuming quiet a bit of cpu for drawing stuff. When using top, chromium is using few % when idle basically)

Remember to run with:

$ chromium --disable-seccomp-filter-sandbox

(probably due to the bug in the old kernel, seccomp and seccomp filter is in 3.10.65 according to /proc/config.gz)

Packages:

http://repo.linaro.org/ubuntu/linaro-ove...m-browser/

Debian bug: https://bugs.debian.org/cgi-bin/bugrepor...799939#113

There should also be 49.0 in debian experimental, didn't checked it yet.

Hi there I'm new in this forum. I'm struggling trying to make chromium work like it should do but the procedure you describe let the browsing safety "uncovered" and, since this is the only device I've to study at the moment I'd prefer to solve the problem in different ways. I get the error with seccomp and sandbox, is there anyone that knows how could I fix it? thank you so much for your attention

The chromium is now available in Debian in testing and unstable: https://packages.debian.org/search?keywo...ection=all

Just run apt-get update && apt-get install chromium from root.
(01-02-2017, 12:25 PM)baryluk Wrote: [ -> ]The chromium is now available in Debian in testing and unstable: https://packages.debian.org/search?keywo...ection=all

Just run apt-get update && apt-get install chromium from root.

I just did it:

Code:
sudo apt-get install chromium-browser

when I ran chromium, it shows the popular "Aw, snap!" display, no matter what menu I click, i.e. settings, about, all the same...
Now will try to install from linaro repo .......
(02-07-2017, 08:06 AM)victagayun Wrote: [ -> ]I just did it:

Code:
sudo apt-get install chromium-browser

when I ran chromium, it shows the popular "Aw, snap!" display, no matter what menu I click, i.e. settings, about, all the same...
Now will try to install from linaro repo .......

then I remove it:

Code:
[email protected]:~$ sudo apt-get --remove purge chrom*

then download as zip those files in google drive and unzip, here are the file :

Code:
[email protected]:/media/ubuntu/03_32GB$ ls
camera
chromedriver_50.0.2661.75-2_arm64.deb
chromedriver-dbgsym_50.0.2661.75-2_arm64.deb
chromium_50.0.2661.75-2_arm64.deb
chromium-browser_50.0.2661.75-2_arm64.changes
chromium-dbgsym_50.0.2661.75-2_arm64.deb
chromium-l10n_50.0.2661.75-2_all.deb
drive-download-20170207T231214Z.zip
iBoy.2017.1080p.NF.WEBRip.DD5.1.HEVC.x265.mkv
wbfs.torrent
[email protected]:/media/ubuntu/03_32GB$

 then did

Code:
[email protected]:/media/ubuntu/03_32GB$ sudo gdebi chro*

 I got this :

Code:
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: chromium (= 50.0.2661.75-2)

any ideas?
Code:
[email protected]:/media/ubuntu/03_32GB/53$ ls
chromedriver_53.0.2785.143-1.1linarostretch1_arm64.deb
chromedriver-dbgsym_53.0.2785.143-1.1linarostretch1_arm64.deb
chromium_53.0.2785.143-1.1linarostretch1_arm64.deb
chromium-browser_53.0.2785.143-1.1linarostretch1_arm64.log.gz
chromium-browser_53.0.2785.143-1.1linarostretch1.debian.tar.xz
chromium-browser_53.0.2785.143.orig.tar.xz
chromium-dbgsym_53.0.2785.143-1.1linarostretch1_arm64.deb
chromium-l10n_53.0.2785.143-1.1linarostretch1_all.deb
[email protected]:/media/ubuntu/03_32GB/53$ sudo gdebi chro*
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: chromium (= 53.0.2785.143-1.1linarostretch1)

[email protected]:/media/ubuntu/03_32GB/53$ sudo apt install -f
Reading package lists... Done
Building dependency tree      
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:/media/ubuntu/03_32GB/53$

I got it!

Code:
sudo apt-get install chromium-browser

run chrome, chromium, chromium-browser

Code:
[email protected]:~$ chrome
bash: chrome: command not found
[email protected]:~$ chromium
bash: chromium: command not found
[email protected]:~$ chromium-browser
[1:1:0208/211749:FATAL:sandbox_seccomp_bpf_linux.cc(146)] Check failed: 1 == (*__errno_location ()) (1 vs. 9)
#0 0x007fb7858e50 base::debug::StackTrace::StackTrace()
#1 0x007fb78753ac logging::LogMessage::~LogMessage()
#2 0x007fb5d9073c <unknown>
#3 0x007fb5d8f8f4 <unknown>
#4 0x007fb5d8fd6c <unknown>
#5 0x007fb5e73770 content::RendererMainPlatformDelegate::EnableSandbox()
#6 0x007fb5e73588 <unknown>
#7 0x007fb588e124 <unknown>
#8 0x007fb588e698 <unknown>
#9 0x007fb588d818 content::ContentMain()
#10 0x0055644c4290 ChromeMain
#11 0x007fb09a78a0 __libc_start_main

Received signal 6
#0 0x007fb7858e50 base::debug::StackTrace::StackTrace()
#1 0x007fb785929c <unknown>
#2 0x007fb7a45510 ([vdso]+0x50f)
#3 0x007fb09b9528 gsignal
[end of stack trace]
[email protected]:~$

add filter box


Code:
[email protected]:~$ chromium-browser --disable-seccomp-filter-sandbox
Has anyone tried to compile chromium 55+ yet?

I was hoping the same netflix pi fix would potentially work on the Pine. Rpi is on chromium 56 as seen below:

https://www.raspberrypi.org/forums/viewt...3&t=176402

I didnt want to try it without getting some insight here before hand.
Pages: 1 2 3 4 5 6 7