NVME dirive doesn't show up - Printable Version

+- PINE64 (
+-- Forum: Pinebook Pro (
+--- Forum: Linux on Pinebook Pro (
+--- Thread: NVME dirive doesn't show up (/showthread.php?tid=9430)

NVME dirive doesn't show up - rleasle - 03-14-2020

I finally got around to installed my nvme adapter and an SSD. A Sabrent Rocket Nano SB-1342-512 (listed as OK in the wiki). The SSD works as expected on every OS I've tried booting from an SD card (Debian, Ubuntu, Manjaro, Q4OS). The eMMC has the default Debian that came with the machine (update-to-date with both apt-get update/upgrade and the script).

The OS on the eMMC shows no sign I can find that the drive is there - no /dev/nvme* entries, nothing from lspci. modprobe shows the nvme modules present. I even went as far as to re-load the eMMC with the latest available debian image. The SSD showed up after the reload, but by the time I finished updating everything (as described above) and re-booted, it was gone again ???

So I'm hoping someone has a suggestion of where to look for error messages, diagnostics to try, ... The SDD works fine when booted from SD card (so I don't believe it's a hardware issue). It even works with the default Debian load, fully updated (like the one I put on the eMMC). What Am I missing?

I haven't tried loading a different OS on the eMMC yet. Thought I'd reach out before trying any more reloading ...

RE: NVME dirive doesn't show up - wdt - 03-14-2020

Have you tried ,, dmesg | grep nvme

RE: NVME dirive doesn't show up - belfastraven - 03-15-2020

(03-14-2020, 10:44 PM)wdt Wrote: Have you tried ,,  dmesg | grep nvme
If you have nvme-cli installed, and/or smartmontools,  you can run smartctl -a  on the drive or various nvme commands  (e.g. sudo smartctl 
-a   /dev/"your device" or sudo nvme  error-log  /dev/"your device".  to see if the device reported any errors.  The logs seem to be cumulative,  so you should pick up any errors from your emmc boot.

RE: NVME dirive doesn't show up - rleasle - 03-15-2020

Looking at the output of dmesg, there seems to be an issue initializing the pci bus, so it doesn't even get to setting up an nvme module. And yet the same OS load running on an SD card is fine. Maybe I should just give up and switch to Manjaro ...