PINE64
Problems with UBPorts downloads - Printable Version

+- PINE64 (https://forum.pine64.org)
+-- Forum: PinePhone (https://forum.pine64.org/forumdisplay.php?fid=120)
+--- Forum: General Discussion on PinePhone (https://forum.pine64.org/forumdisplay.php?fid=127)
+--- Thread: Problems with UBPorts downloads (/showthread.php?tid=9285)



Problems with UBPorts downloads - bcnaz - 02-25-2020

*
  I have been fairly impressed with the progress UBPorts is making with each new release.

             BUT

I have not been able to complete a download of their Feb. 25, 2020 edition.

I have made over 40 'failed' attempts starting about 2 hours after they released it until about

12 hours after this release.

The download speeds vary greatly from 100+kb/sec to 3mb/sec, 
   wondering if there is a server problem or too many attempting to download at the same time ?

Any one else having this problem ?  OR  Just me,  maybe the problem is at my end...?


UPDATE :
I have found that just clicking "retry" does continue the download...
AND so far these downloads have worked when I flash them using Balena Etcher....

Just a bit Frustrating, sometimes it is just a few 'retrys'
Sometimes many 'Retrys'


RE: Problems with UBPorts downloads - mattpenn - 02-27-2020

I can confirm that I observed the same issue.


RE: Problems with UBPorts downloads - soyrunner - 02-28-2020

Have your tried wget --https-only? My experience has been the download gets interrupted after about 1 minute as if they want us to have a very fast download capability. Still, wget --https-only will resume the transfer after a few seconds. Then one must verify the compressed file is okay using one of the 7zip options. I think it took 3 downloads, all with interruptions, before I got a valid compressed file. Still, it's fairly fast and not too much trouble.

soyrunner


RE: Problems with UBPorts downloads - d0n601 - 02-29-2020

I cant even get the download to finish using a browser unless I sit there pressing retry over and over. I've resorted to downloading the new releases with wget using infinite tries.

Code:
wget --tries=0  https://ci.ubports.com/job/rootfs/job/rootfs-pinephone/lastBuild/artifact/ubuntu-touch-pinephone.img.gz



RE: Problems with UBPorts downloads - wtdonnelly - 03-02-2020

(02-29-2020, 12:34 AM)d0n601 Wrote: I cant even get the download to finish using a browser unless I sit there pressing retry over and over. I've resorted to downloading the new releases with wget using infinite tries.

Code:
wget --tries=0  https://ci.ubports.com/job/rootfs/job/rootfs-pinephone/lastBuild/artifact/ubuntu-touch-pinephone.img.gz

I just got the image using wget without any problems.  Took ~5 min to Hanover, NH, USA.


RE: Problems with UBPorts downloads - d0n601 - 03-04-2020

(03-02-2020, 09:43 AM)wtdonnelly Wrote:
(02-29-2020, 12:34 AM)d0n601 Wrote: I cant even get the download to finish using a browser unless I sit there pressing retry over and over. I've resorted to downloading the new releases with wget using infinite tries.

Code:
wget --tries=0  https://ci.ubports.com/job/rootfs/job/rootfs-pinephone/lastBuild/artifact/ubuntu-touch-pinephone.img.gz

I just got the image using wget without any problems.  Took ~5 min to Hanover, NH, USA.

It was really bad for a couple days. Now I'm getting similar results as this. My speeds have jumped up to Mb/s as opposed to a like 100k/s and it doesn't disconnect me anymore during the downloads. Odd but a welcomed changed Smile


RE: Problems with UBPorts downloads - bcnaz - 03-25-2020

I guess part of it is just the nature of the WWW internet.

I installed a new copy of Firefox Quantum and while the speed did vary a bit, it completed the download without disconnecting even once.

BUT,  the next day even the 'new' browser disconnected a few times.

I tried the download from my sons house, it finished in mere minutes never dropping under 3mb/sec.

....  so far all the downloads have loaded and played from the SD cards,  that's what matters.


RE: Problems with UBPorts downloads - bcnaz - 04-02-2020

another update :
I am wondering if there is some kind of censorship on some lines into the USA ?
UT #270, it disconnected an average of about 30mb between disconnect/retry.
speeds as low as 7.4 kb/sec... This was doing the 1+gb download.
I am paying over $110. USD monthly to Trans/World for this kind of service...