debian+phosh running on PinePhone - Printable Version

+- PINE64 (
+-- Forum: PinePhone (
+--- Forum: PinePhone Software (
+---- Forum: Mobian on PinePhone (
+---- Thread: debian+phosh running on PinePhone (/showthread.php?tid=9016)

RE: debian+phosh running on PinePhone - BlackWater - 03-17-2020

(03-16-2020, 06:02 PM)a-wai Wrote: apt should be enough (nearly all customizations have been moved to deb packages), but you might need a few tricks to make sure everything goes fine (e.g. check the debian user belongs to all the needed groups -- see the setup-user script on gitlab)
Also, please make sure you have task-pinephone-phosh installed.
Anyway, you can just backup your data, try an upgrade, and go back from a clean install if anything goes wrong Wink

Thanks a lot! Big Grin

RE: debian+phosh running on PinePhone - cefre00 - 03-17-2020

I tried this one too and have to say so far this is the closest to a final mobile OS. Great work, thank you for that! Smile
The only thing what keeps me from using this as a daily is the battery life, and this is not a complaint. Pls don take it as such.

From the end user perspective:
- Calls tested and working as they should both on 2G and on 4G. This is the first time this phone was actually ringing out loud! Big Grin You should have seen my face.
- Added some names into the Phonebook, PP could see them and retrospectively update the called ones in the recent list, but only if both records were using the "+xx" country prefix. For me its a given and maybe people can be reminded that please use this and not just "06".
- Mobile data I couldn't test, I have a call only SIM right now. I'll update my contract and test it later.
- Wifi works great, can switch it off and on. After restart functional again. (I did not know PP has "only" 2.4 GHz antenna, also NOT A COMPLAINT, just did not know).
- SMS works too. No notification though. Once I set it up for the given chat there is a pop-up notification, but nothing on the top bar and no sound. This app needs some love. Is it possible to use the "Spacebar" app here? Manjaro has it, it seems to be a more capable one. This one does not see the records in the Phonebook.
- I installed another terminal, so that is fine too and I could update the system with the usual method (apt-get), could use the terminal as I remembered from my Ubuntu days. Big Grin
- Cheese did not show any picture so far. Camera is not important for me, so I did not really test this.
- Could not install new languages for the keyboard. It will come I suppose not critical for me, just tried.
- I could set the time zone: the OK button was out of bounds, but just quit the settings and it kept my setup so it is working.
- Positioning with wifi on was promptly done, as soon as the "Maps" app loaded I swiped the map and the dot was there in the right place. Impressive! Smile
- But what I liked the most: this OS was running from the average Class10 SD card and was almost perfectly smooth! Great experience, the same actually what SFOS provided.

So far this is great! Actually more than great! Big Grin I like it really very much. Now I have UBports and this image flashed on cards. Will run update daily. I will not spam this thread, just wanted to share my first impressions after trying many other OSs for the PP (SFOS, KDE Neon, Manjaro, and these 2).

RE: debian+phosh running on PinePhone - rico - 03-17-2020

You just wanted to share and did it very well.
Thank you for that.

RE: debian+phosh running on PinePhone - Luke - 03-17-2020

@a-wai So I did get suspend going on the build and bat life is looking solid - 10% drain in ~ approx. 75 min, so similar to what I saw on KDE Neon* ; that said the LTE modem doesn't come back online. Are you in the dev chat? - if not, perhaps consider joining and talking to Bhushan about how he got the modem to (mostly) stay online during suspend? I am pretty sure that, basically, USB 2.0 remains active in suspend with whatever tweak KDE Neon uses.

*This isn't super accurate because the battery discharge isn't linear. I expect the bat life is 10-12 hrs.

RE: debian+phosh running on PinePhone - buskmann - 03-17-2020


Just installed the latest image on an SD card, and i have to say, this is very close to daily driver for me. Great work!

I wanted to try to build my own image using the debos-pinephone recipes, but it complained about this:

2020/03/17 19:00:22 open failed: /lib/modules/5.3.0-40-generic/kernel/drivers/virtio/virtio.ko - open /lib/modules/5.3.0-40-generic/kernel/drivers/virtio/virtio.ko: no such file or directory
2020/03/17 19:00:23 open failed: /lib/modules/5.3.0-40-generic/kernel/drivers/virtio/virtio.ko - open /lib/modules/5.3.0-40-generic/kernel/drivers/virtio/virtio.ko: no such file or directory

Tried to write the image with etcher, and there was no partitions in the image.

Is there something i can do to fix this? Im guessing it has to do with my current computer setup (kubuntu) and not debos-pinephone.
I have been using Linux for at least 10 years, but im not really tech savvy.

RE: debian+phosh running on PinePhone - bcnaz - 03-17-2020

Not sure if this is pertinant

Could be OS, or the APP,  or just me ?

When I am using the text app for an extended amount of time the whole system seems to freeze ?
The only recourse (for me) is to hold the power button until it powers down, then restart.

Then it runs fine for a few more hours.
   but if I continue long enough it will freeze again.

Otherwise this OS is really amazing so far.

Thanks !

RE: debian+phosh running on PinePhone - buffer - 03-18-2020

Hello Debian Phosh friends!

Well I built the latest image today (for the last time I think, I will start using apt update) for my daily use this time with Jumpdrive since I was messy with dd the last few times. So, brand new installation again.

I have a Mint Mobile 7 day trial activated for it and as everyone else said the calls and texts just work (you just have to remember, when sending new texts, +1 and the number) however I am still having a problem with calls... When I call my nearby friend, I can hear them, but my friend can't hear me. Before I send a bug report, has anyone else checked whether the person on the other line can actually hear you?

Attached is a voice sample of what it sounds like. Believe it or not that's what it sounds like when I try to say hello over and over directly into the mic. [edit: looks like the attachment is not allowed. OK basically it sounds like almost nothing, a faint wind perhaps.]

Well, off to file my bug report.

P.S. Currently the battery life is 6 hrs sitting idle.

@buskmann I'm using Debian Buster to build successfully... Your issue is the same one as on page 2 of this thread, basically building is broken in Ubuntu)
I have added more instructions to the pine64 wiki as far as how to install to eMMC, etc, including the new Jumpdrive.

I heard back from Debian wiki, so soon I will start adding documentation about Debian + Phosh on ARM64 Smile at least so people can know that Debian does run on PinePhone. And at least so I can update progress on ARM64 ports if I get some of those done, now that I have this device.

I also tried the wlr-randr hack as implemented by @nas here with the extra c library, it's a nice workaround and makes Firefox, and other apps, somewhat more usable. The only major problems so far then are not being able to speak in phone calls and the keyboard itself, squeakboard, can be frustrating as it is not very responsive or sometimes too responsive - I chalk this down to it needing more development.

I said I would try migrating to Devuan and I did try: but since [2nd instruction ask you to run update-alternatives --config x-session-manager, and well we are using Wayland, so I guess it doesn't work and it's looking for a program called Dialog. I prefer Wayland over X, a lot more than I care about the init. I guess that concludes my exploration with migrating from Debian to Devuan on the PinePhone.

RE: debian+phosh running on PinePhone - a-wai - 03-18-2020

(03-17-2020, 01:24 PM)Luke Wrote: Are you in the dev chat? - if not, perhaps consider joining
@Luke not yet, actually I looked for something like that in the wiki a while ago and couldn't find anything specifically aimed at developers, do you have a link to share please?

(03-17-2020, 02:23 PM)buskmann Wrote: I wanted to try to build my own image using the debos-pinephone recipes, but it complained about this:
Yes, this seems to be a known issue with ubuntu, probably some kernel modules you need to install...

(03-17-2020, 04:30 PM)bcnaz Wrote: Could be OS, or the APP,  or just me ?
Probably a bit of both the OS and app, for now we're focusing on harware enablement (and, later on, power management), but we'll certainly get back to that king of bugs in the future Wink

RE: debian+phosh running on PinePhone - buskmann - 03-18-2020

Thanks for the response.

Wanted to try to build the image on the pinephone itself, but i see that debos is not in the repos.
Nevertheless its about time to distrohop again, so will go for debian now.

Just wanted to share somethings i have found:

I installed growpart to expand the partition with:

sudo apt install cloud-guest-utils

and continued with:

growpart /dev/mmcblk2 1

and it spit out:

FAILED: sfdisk not found

then i did:

whereis sfdisk

and this came out:

sfdisk: /usr/sbin/sfdisk /usr/share/man/man8/sfdisk.8.gz

Dont know where to go from there..

Also i find that "ip" is not installed. That is part of the "net-tools" package right? And "net-tools" is installed.

But in the end i really love the image.
Thanks again for the awesome work. Big Grin

RE: debian+phosh running on PinePhone - BlackWater - 03-18-2020

(03-18-2020, 10:31 AM)buskmann Wrote: Also i find that "ip" is not installed. That is part of the "net-tools" package right? And "net-tools" is installed.

ip is in iproute2