Frustrations with Wifi, VNC, Longsleep, etc. - Printable Version

+- PINE64 (
+-- Forum: PINE A64(+) (
+--- Forum: Linux on Pine A64(+) (
+---- Forum: Ubuntu (
+---- Thread: Frustrations with Wifi, VNC, Longsleep, etc. (/showthread.php?tid=7560)

Frustrations with Wifi, VNC, Longsleep, etc. - NexusDude - 06-04-2019

My inexperience with Linux is the main problem. I'm used to solving my own technical problems, especially now that we have the Internet! With Linux, though, I keep running into walls that I have trouble overcoming.

I suspect, though, that some of my frustrations in installing wifi dongles on an A64+ may be due to bugs with software, whether Longsleep's image or other software I've installed.

Here are my steps, and the results. I'll mention installing VNC because that was a step I took. I'm still hopeful that I can get that going, but I'm open to all suggestions:  Tongue

1. Balena Etcher flash of xubuntu-xenial-mate-20161215-longsleep-pine64-8GB.img.gz onto 64gb micro SD (since I ran out of room with previous attempt using 32GB) -- Result great!

2. Sudo

3. Sudo apt-get update a couple times. Plus sudo apt-get upgrade and sudo apt autoremove a couple times.

4. Sudo apt-get install vnc4server -- Result: never did get it working as I have on Rasp Pi 3B+

5. Sudo apt-get install nano build-essential linux-headers-generic git

6. Mkdir ~/RTL8188EU

7. cd to above

8. git clone git://
434 objects enumerated
434 of 434 objects counted
310 of 310 objects compressed
received 100% (12615/12615)
resolved deltas 100% (9368/9368)
connectivity checked

9. cd to ~/RTL8188EU/rtl8188eu

10. make all
make ARCH=arm64 CROSS_COMPILE= -C /lib/modules/3.10.104/build M=/home/ubun/RTL8188EU/rtl8188eu  modules
make[1]: *** /lib/modules/3.10.104/build: No such file or directory.  Stop.
Makefile:151: recipe for target 'modules' failed
make: *** [modules] Error 2

11. Tried make instead of make all. Same result.

12. Looked in /lib/modules/ to confirm that there's a 3.10.104 folder.

13. Looked in /lib/modules/3.10.104 folder to find shortcut called "build". So it's /lib/modules/3.10.104/build. Looked at properties. The target is: /home/hxwong/build-pine64-image/linux-pine64
This will fail, right? If anything tries to build/make, whatever, it'll look for hxwong instead of ubun or whatever you have.

What did I miss? What should I do (or not have done)?

Early Kickstarter of Pine A64+

RE: Frustrations with Wifi, VNC, Longsleep, etc. - igorp - 06-05-2019

You have too big expectations for the prehistoric kernel (3.10.y) and the system you are trying to use for this task. 

Grab Armbian to fast forward to best possible experience. With modern kernel this wifi should work plug and play. If you insist to use 3.10.y for some reasons .. headers are available (install them from armbian-config) and you might get lucky to compile this module. It is also dependent from the driver code ... not just from the host system.