issue with kodi freezing randomly - Printable Version

+- PINE64 (
+-- Forum: ROCKPRO64 (
+--- Forum: Linux on RockPro64 (
+--- Thread: issue with kodi freezing randomly (/showthread.php?tid=7519)

issue with kodi freezing randomly - Slam - 05-22-2019

HI there,

I have the NAS case with the RP64. I installed the latest MrFixit image on it and managed to install/setup:
- samba (to have a network drive) 
- Rsync (to backup the network drive)
- remove pulseaudio to avoid random freeze as it's currently an unresolved issue)

- install Kodi to have a media center (to read the video / music / photos I save on the HDD)

the issue is with Kodi as when I run it I get random freeze (where nothing is working anymore (no ssh, no network access, image on screen is frozen). The freeze has the same behavior as the issue caused by pulseaudio.

Would anyone have a working kodi (other than the specific distro available)?

What has kodi in common with pulse audio? this issue might be linked with the pulse audio issue somehow and I would like to resolve it if possible.

Thanks for anyone reading / helping!

RE: issue with kodi freezing randomly - Slam - 05-23-2019

Small update on this:
- I'm sadly not able to capture UART output as I don't have the required equipment for it Sad

- I'm using the Desktop image from MrFixit2001

- When I run "top" to get details on Ram & CPU and check the temperature of the board there is nothing visibly problematic displayed before the freeze. Ram, cpu & temp are all stable and low.

RE: issue with kodi freezing randomly - Slam - 05-24-2019

- I got myself a UART connector to see if anything would come out on the serial port but nothing come out sadly.
- I tested without the PCIe and Kodi work with no freeze then

It look like the issue with pulseaudio freezing the board if the PCIe card is connected. I'm not sure what Kodi and pulseaudio have in common though :S

RE: issue with kodi freezing randomly - mknawabi - 05-24-2019

Today, I tested the mrfixit desktop build + Kodi. With a X540 10gig copper Intel NIC (detected via lspci -vvv but not network tested), Kodi launched without an issue. If I end up getting a SATA card I will update here.