Have eMMC adapter - but can't seem to fix eMMC card - Printable Version

+- PINE64 (
+-- Forum: ROCK64 (
+--- Forum: Rock64 Hardware and Accessories (
+--- Thread: Have eMMC adapter - but can't seem to fix eMMC card (/showthread.php?tid=7277)

Have eMMC adapter - but can't seem to fix eMMC card - SirRyanTheGeek - 03-18-2019

Hi - I had purchased two Rock64 boards, two 64GB eMMC chips and the USB adapter - got the image onto one of the cards using Balaena Etcher (been working great to get images on to microSD cards and the like). Went and re-formatted it after plugging it back into my Windows machine, went to reset an image - but now the eMMC card only appears as a 14.4 GB removable drive called "CARD" on drive E: and I can never seem to delete the partition, format the drive or anything else with it.

Things I've tried:

Volume manager and DISKPART on windows - all the way to deleting the partition - even forcing the delete
Plugged it into the Pi's USB port and using "sudo fdisk" and trying everything I could google to remove it to redo the drive to no avail.

The only thing that seems to show up now is a DOS partition that always has a "uupd.bin" file in it - and I can never reformat it. Is there something magical - or set of steps to get that rogue volume off the eMMC and back to where I can use it like the 64GB chip it is?

Is this chip lost for eternity or is there a way to really access it, blow it all away and redo it from scratch? Until I can figure something out I am afraid to take the other eMMC out of the bag. 


RE: Have eMMC adapter - but can't seem to fix eMMC card - z4v4l - 03-20-2019

Of course, it's not lost. You should have flashed it (with that etcher), insert into rock64 and use. why did you do differently? I guess, you use an image that has rockchip GPT partitioning with a lot of partitions. it might cause many old utilities to behave erratically, some partitions might have IDs indicating their "special" role on the system, prohibiting a compliant environment to mess up with them. you need some hammer. Big Grin maybe you try armbian with their good old MBR scheme and just 1 partition. try use windiskimager for flashing it and let armbian resize its volume on the first boot. there are also tons of other methods to get your eMMC back to the normal state. for example - insert it into rock64 booted with sd card and fill some first megabytes of the raw device with zeros. with dd. make sure you zero eMMC, not SD card. Big Grin

RE: Have eMMC adapter - but can't seem to fix eMMC card - MotoTom - 03-25-2019

I'm having a similar problem with my 16GB Emmc drive.

I keep getting an error message "Drive has been unplugged" when using the Pine64 Installer using the Pin64 USB > emmc device. I did a full SD Format without any errors. In addition to the Pine64 Installer I've tried Etcher v1.5.5 and HDDRawCopy1.10 with the same sad result. I've tried using dd on my linux-lite netbook and still no joy. I successfully copied 13GB of movies (17 files) to it without a problem so it looks like the drive itself is OK.

FWIW, I'm trying to install either stretch-minimal-rock64-0.7.9-1067-arm64 or stretch-openmediavault-rock64-0.7.9-1067-armhf

Sure would appreciate any suggestions that get thiis resolved.

RE: Have eMMC adapter - but can't seem to fix eMMC card - burito111 - 05-04-2019

Same problem here. I tried to flash Ubuntu Bionic on my eMMC 32GB card and Linux didn't boot. When I connected the eMMC card to my PC through Pine USB adapter it showed in Windows only 14.6GB. I tried the same in Linux with Gparted and fdisk, they show the same. However there is an information about W95/FAT32 disk, even when partitions has been deleted. Is there something I can do? In addition I had similar issue with eMMC 64GB, but then I assumed it is because of some kind of spark damage. Any ideas?