Custom Kernel for ROCK64 - Printable Version

+- PINE64 (
+-- Forum: General (
+--- Forum: Getting Started (
+--- Thread: Custom Kernel for ROCK64 (/showthread.php?tid=6996)

Custom Kernel for ROCK64 - mayst - 12-27-2018

Dear Pine Users,

thank you for providing the discussion group for the ROCK64 platform. I tried to use a custom compiled kernel for several days now. Unfortunately, every attempt results in a system that does not boot.

The most promising way seemed to me the following with a newly installed distribution via Etcher. I took the Ubuntu 18.4. Desktop variant. Then I have executed the following commands on-board:

sudo dpkg-reconfigure keyboard-configuration

sudo dpkg-reconfigure tzdata

sudo apt update

sudo apt upgrade

sudo apt -y install cmake build-essential python-minimal bison flex bc libssl-dev libncurses5-dev lzop make u-boot-tools binfmt-support ninja-build libfl-dev python python2.7 swig libpython-dev flash-kernel

sudo reboot

mkdir workspace

cd workspace

git clone

cd linux-mainline-kernel

make rockchip_linux_defconfig

make -j4

sudo make modules_install

sudo make dtbs_install

sudo make install

After this, the platform will not reboot. I just get a black screen. The LEDs of the ROCK64 just light up a few seconds. Then only the green LED remains.

I have checked the file /boot/extlinux/extlinux.conf
If I remove the entries for the newly installed kernel, the platform boots with the old kernel again (4.4.).
By the way, why do I have /boot/extlinux/extlinux.conf and /boot/efi/extlinux/extlinux.conf?

I hope, you can give me a hint, what is missing or how I can debug this issue, since I do not see any output, also not from u-boot.

Best regards,

   Stefan May

RE: Custom Kernel for ROCK64 - spatial_dreams - 01-07-2019

I'm also interested in this issue. What steps are required to make a custom kernel image bootable on a rockpro64?

RE: Custom Kernel for ROCK64 - mayst - 01-07-2019

Meanwhile, I solved my problem by myself. The kernel source snapshots at github are not all bootable. I tried to use the 4.20. kernel but with no success. Since I have no serial console, I was not able to figure out what was going wrong with the new kernel.
The 4.19. kernel, I could boot, but with no HDMI output. In the end I took the version 4.4.132-1075-rockchip-ayufan from [url=][/url]
You can download this version here:
I took the configuration from /proc and modified the config file to my needs (activated CAN interface).

Please let me know, if you manage to boot any newer kernel.