USB Errors with ASI camera - Printable Version

+- PINE64 (
+-- Forum: ROCK64 (
+--- Forum: Linux on Rock64 (
+--- Thread: USB Errors with ASI camera (/showthread.php?tid=6553)

USB Errors with ASI camera - GuLinux - 09-18-2018

I'm trying to use my Rock64 board to automate astronomical observations, I mainly use an ASI camera ( and a filter wheel.
The camera is USB3, and provides its own USB2 hub to attach other peripheals (like the filter wheel). The camera USB hub can be externally powered (and it currently is), so current shouldn't be an issue.

I tried different configurations for the ubuntu images (both armbian and ayufan):
 - 18.04 32bit: worked pretty fine at some point, but with some instabilities here and there while shooting. The latest installation though seems to fail pretty much consistently after circa 17 shots, I'm seeing lots of these messages on my kernel log:
Sep 18 08:38:07 rock64 kernel: usb 5-1: usbfs: usb_submit_urb returned -12
Sep 18 08:38:07 rock64 kernel: xhci-hcd Ring expansion failed
- 18.04 64bit: never got it working. As soon as I try to connect to the camera, the program hangs, and kernel shows this message:
Sep 13 08:46:39 rock64 kernel: Unhandled fault: alignment fault (0x92000021) at 0x000000559a47669c
 - an older 16.04 image seemed to work pretty much fine, but I had a few instabilities/failures at some point (I don't remember the details, but I'll try again later) 

The camera itself works well with my laptop. I don't know if it's a kernel issue, a faulty board, or the camera SDK having some weird bug. There are however reports of ASI cameras working pretty fine on other rock64 boards, so I think I can exclude some kind of incompatibility.

Do you have any hint on how to solve this?