Windows 10 and .Net Core running for a day - Printable Version

+- PINE64 (
+-- Forum: PINE A64(+) (
+--- Forum: Windows 10 IoT (
+--- Thread: Windows 10 and .Net Core running for a day (/showthread.php?tid=4974)

Windows 10 and .Net Core running for a day - hugob - 08-19-2017


I have Windows 10 IOT running on my Pine64 2Gb. Everything looks OK. I can manage it via SSH and also via the device portal (port 8080).
I have keyboard, mouse, internet, and Bluetooth.
I even have a small .Net Core "Hello World" app running on it (!).
But the problem is after about a day, I see an animated gearbox and the system is dead. Has nothing to do with the .Net Core app. It looks like a memory leak in the system. Anybody has the same problem and/or knows a solution?


I know it is bad to reply to your own message. But in case someone is interested. These are the steps to get this working:

Get Win10-IOT running on Pine64.
  1. Download the latest image ( and burn it on an SD-Card. This sounds easy but it is not. You have to convert a ffu file to a disk image. The python script I tried did no work. I succeeded with the IOT Dashboard on a Win10 laptop. In my case it ended after 99% with an error (could not write blabla..) and a Windows popup that I have to format this disk. Do not do that. Just pull the SD-Card out.
  2. Plug the SD-Card into your Pine64. Make sure it is connected to the local network and you have a DHCP server running. Apply power and wait for 5 minutes. You can see by the LED near the UTP connection that it is doing something.
  3. I had a HDMI monitor attached and a Logitech wireless keyboard/mouse plugged in in the lower USB. A language select menu was displayed on the screen, but the keyboard was not recognized. After half a minute the default language is selected and an overview is displayed. For me it displayed two IP addresses but no connected devices.
  4. Now you can connect to your Pine64 via SSH with the regular IP address (not the kernel debug one). Username/password is [email=Administrator/p@ssw0rd]Administrator/p@ssw0rd[/email] You can also inspect your system via the portal http://<YourPine64IP>:8080 with the same username/password.
  5. I connected a USB switch to the lower USB and attached the keyboard and a usb memory stick to the switch. I tried several keyboards but they did not work. I attached an old cheap Sweex BlueTooth adapter to the switch and to my surprise I could see in the portal that it was working. And now also the Logitech keyboard was working and the USB stick was recognized as D: drive. And they were all diplayed in the overview under connected devices. I doubt whether this has something to do with plugging in the BlueTooth adapter.
  6. You can mount your Pine64 on a PC with \\<YourPine64IP>\C$ Reading is fast, but writing is very slow (or does not work at all). This also hits you when you try to deploy and debug your App with VisualStudio.
  7. In general SSH is working best. E.g. if you enter D: you are swapped to the D: drive. In the commandline of the Pine64 itself this does not work. Also the disk size is not reported correctly.
  8. Do not forget to turn off the Kernel debugging as mentioned on the Pine64 site.

Step 2. Create a DotNetCore 2.0 app.

  1. Install the DotNetCore 2.0 SDK on your PC.
  2. Follow the instructions from Instead of the pi calculation I did a simple hello world.
  3. Use win-arm in <RuntimeIdentifiers> and publish for this identifier. Do not use win-arm64. I spend a lot of time on this. It looks like this Pine64 IOT build is 32 bit. (Which is not that bad, because now you can use Raspberry PI examples). Run the .exe from the commandline/SSH. I used a self-contained package instead of copying this preview release to Sytem32 on the Pine64.
  4. I transferred files to my Pine64 with a USB stick, because writing via the network is too slow.

RE: Windows 10 and .Net Core running for a day - dkryder - 08-19-2017

have you figured out how to get it to shutdown normally?

RE: Windows 10 and .Net Core running for a day - hugob - 08-23-2017

(08-19-2017, 06:49 PM)dkryder Wrote: have you figured out how to get it to shutdown normally?

You asked the same question in another thread. And there is a clear answer in that thread, It is a Pine64 hardware issue. It reboots automatically, You can pull out the power at the right moment. See other thread.