config error installing XML-RPC on longsleep Ubuntu - Printable Version

+- PINE64 (
+-- Forum: PINE A64(+) (
+--- Forum: Linux on Pine A64(+) (
+---- Forum: Ubuntu (
+---- Thread: config error installing XML-RPC on longsleep Ubuntu (/showthread.php?tid=2956)

config error installing XML-RPC on longsleep Ubuntu - tinkertom - 12-16-2016

I've used the xenial-pine64-bspkernel-20160716-1.img to install the longsleep Ubuntu then did the apt-get update and upgrade.  

EDIT: I just reformatted my card, put on the brand new xenial-pine64-bspkernel-20161217-1.img, did all the other resize, etc, and got the same results below. I' replacing the output from yesterday with the output from today.
I'm trying to install XML-RPC via 
svn co -q /tmp/xmlrpc-c
but when I get to the line:  ./configure
it fails because it is unable to guess the build type.
Has anyone been able to get this to work?  How would I go about checking the URLs in their comment to see if it would recognize this custom build? or how would I specify a build?  
I know this might be more of an XML-RPC support issue, but this has worked fine on other stock Ubuntu builds I've done in the past.
Thanks for any support you can offer.
The output message I get is below:

root@pine64:/tmp/xmlrpc-c# ./configure --disable-libwww-client --disable-wininet-client --disable-abyss-server --disable-cgi-server
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... missing
checking build system type... ./config.guess: unable to guess system type

This script, last modified 2009-12-30, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from;a=blob_plain;f=config.guess;hb=HEAD

If the version you run (./config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <> in order to provide the needed
information to handle your system.

config.guess timestamp = 2009-12-30

uname -m = aarch64
uname -r = 3.10.104-2-pine64-longsleep
uname -s = Linux
uname -v = #113 SMP PREEMPT Thu Dec 15 21:46:07 CET 2016

/usr/bin/uname -p =
/bin/uname -X     =

hostinfo               =
/bin/universe          =
/usr/bin/arch -k       =
/bin/arch              =
/usr/bin/oslevel       =
/usr/convex/getsysinfo =

UNAME_RELEASE = 3.10.104-2-pine64-longsleep
UNAME_VERSION = #113 SMP PREEMPT Thu Dec 15 21:46:07 CET 2016
configure: error: cannot guess build type; you must specify one

RE: config error installing XML-RPC on longsleep Ubuntu - sanah - 02-22-2017

This seems to solve it for me:

cd /tmp/xmlrpc-c
mv config.guess config.guess.bak
mv config.sub config.sub.bak
ln /usr/share/misc/config.guess ./config.guess
ln /usr/share/misc/config.sub ./config.sub

RE: config error installing XML-RPC on longsleep Ubuntu - MarkHaysHarris777 - 02-22-2017

Please use code blocks for readability.