ModemManager debug mode? (Needed to flash modem) - Printable Version

+- PINE64 (
+-- Forum: PinePhone (
+--- Forum: PinePhone Software (
+---- Forum: Mobian on PinePhone (
+---- Thread: ModemManager debug mode? (Needed to flash modem) (/showthread.php?tid=17977)

ModemManager debug mode? (Needed to flash modem) - calinb - 02-27-2023

After replacing my Pinephone's sideboard again (dead microphone for the 2nd time) and the coax cable, my Pinephone can no longer connect to the cellular network (US Mobile T-Mobile MVNO). While I was waiting for parts, I successfully used the SIM card in my old rooted Moto G4 phone while I waited for the parts to arrive.

I can no longer connect to the cellular network. No calls. No SMS. No Internet. Signal strength bars are normal, network is scanned but it will not register. Using ModemManager GUI, it briefly says  "Connecting to US Mobile (Success)" but then vanishes. The symptoms are as described here:

My wife's Pinephone still works on the same network, but I don't dare swap her SIM card out and try it! Dodgy 

So after trying all the stuff in the thread above, I'm ready to flash my modem again (now running . Unfortunately, looks like I now need to activate "debug" mode--either than or boot an older OS from back when my experimental phone was not "secure" or protected from being repaired  Sad .

error: command failed: 'GDBus.Error:org.freedesktop.ModemManager1.Error.Core.Unauthorized: Cannot send AT command to modem: operation only allowed in debug mode'

I run Mobian. How do I enter debug mode with ModemManager / mmcli so I can use AT commands like I did when I flashed the modem 1-1/2 years ago? If I can't figure out how to use the new ModemManager "debug" mode, I still have one of Megi's multi-boot SD cards and it looks like it still works (I'm running

$ mmcli -m any --command='AT+QGMR'

response: 'EG25GGBR07A08M2G_01.003.01.003'

Thanks for the debug mode secret key or any other advice, including your favorite modem firmware these days. ( ???)

Or maybe I should try first.

RE: ModemManager debug mode? (Needed to flash modem) - calinb - 02-27-2023


I booted Megi's multi-boot to an old rev. of Mobian and updated my modem firmware:

mmcli -m any --command='AT+QGMR'

response: 'EG25GGBR07A08M2G_30.006.30.006'

So I guess it worked, but the phone still doesn't work. Guess I'll have to explore and research various settings to set and change.