Pine64 LTS won't boot - Printable Version

+- PINE64 (
+-- Forum: PINE A64-LTS / SOPINE Compute Module (
+--- Forum: General Discussion on PINE A64-LTS / SOPINE (
+--- Thread: Pine64 LTS won't boot (/showthread.php?tid=17961)

Pine64 LTS won't boot - zuvmajujo - 02-22-2023

I've been troubleshooting two Pine64 2G LTS boards for several days now and I haven't been able to get either to boot. I've read the instructions on flashing an SD card and the troubleshooting section in the Getting Started section of the wiki. I've also read the relevant threads in the aptly named Useful Threads posts, yet I haven't gotten a board to boot yet.

I've used balenaEtcher to flash two, known good, SD cards with Armbian 22.11 Jammy XFCE. I also tried the CLI version on both SD cards for thoroughness sake. Still no dice. I flashed the devices on a Windows 10 machine and on a Ubuntu 22.04 machine with the same result. The same SD cards can successfully boot other SBCs I have. I've powered both boards with a known good bench top power supply via GPIO pins 1 and 3 and with a 5V 2A power adapter. I can't actually confirm that the power adapter is good because the LTS boards are the only devices I have that accept the barrel connector. But regardless of how I power the boards, a green power LED lights up. My bench top power supply says the LTS boards are pulling ~125mA if that helps troubleshoot. The same supply can power much hungrier dev boards I have.

I've used two, known good, HDMI monitors with two, known good, HDMI cables to see if screen resolution was the problem, but that still didn't work. I connected a known good Ethernet cable to both LTS boards and there is no activity on the pine 64 nor the port on the router. The same port and same cable plugged into other devices supplies Ethernet and lights up the jacks on both ends. I left a board on for a while and checked devices connected to my router just to see if it had an IP address, but no dice.

I even tried randomly pressing the power and reset buttons to see if that changed anything, but I'm seeing no signs of life from either of the boards I have. Since I can't even SSH into either device I've basically exhausted all the trouble shooting options I can think of. All the tools I'm using are working with other devices on my bench.

I tried flashing an SD card with Manjaro to see if it was an Armbian problem but couldn't get the installer to run on my Ubuntu machine. I intentionally buy two devices when bringing up new-to-me devices to rule out a DOA board. The fact that I have two boards that refuse to boot makes me think I'm doing something wrong. This isn't my first rodeo with open source hardware, but I'm out of ideas. Any troubleshooting suggestions will be greatly appreciated.

RE: Pine64 LTS won't boot - zuvmajujo - 04-02-2023

The problem turned out to be the Armbian image I was using. Armbian does not distinguish between the Pine64(+) and the Pine64-LTS. The LTS' getting started section even links to Pine64(+) images. According to Armbian devs, Pine64 did not tell them about the difference in hardware, and thus the poorly linked documentation. The correct images for the Pine64-LTS, and presumably the SOPine, are categorized as pine64so.

Can someone at Pine64 communicate the difference to Armbian devs? Or at least change the linkĀ  in the getting started page?