PBP green LED works but blank display. - Printable Version

+- PINE64 (
+-- Forum: Pinebook Pro (
+--- Forum: General Discussion on Pinebook Pro (
+--- Thread: PBP green LED works but blank display. (/showthread.php?tid=17959)

PBP green LED works but blank display. - frerebo - 02-21-2023

Hi, recently ordered pinebook pro. For the first couple days it worked just fine, and then one day the display just completely stopped working. As far as the green LED is concerned, it powers on and off just fine whether plugged in or on battery.

Sorry I'm new to this, but here's what I've done so far (spoiler alert none of it has worked):

1. Took the base off, and hit the reset button (and I made sure the emmc module switch was on).
2. Demonstrated my Galaxy brain intellect by taking the base off again, disabling the emcc switch, spent 5 hours backing up several years of important stuff stored on my SD card, flashed Armbian to the SD card, and then realized the PBP doesn't actually have a full sized SD slot. Turned emmc switch back on.
3. Downloaded Manjaro, wrote it to a USB drive using and tried to boot that way.
4. Connected a USB-C cable to a USB-C monitor.

I'm still a bit lost on all the USB versions so I'm not 100% sure if the USB-C cable I grabbed supports DP alt mode, but I'll double check that when I get off work here in a few minutes. If that doesn't work, my next idea is to redownload Manjaro, flash it to a USB drive with Etcher, disable the EMCC switch and attempt to boot that way. aaaand if that doesn't work my next thought would be to take advantage of the 10000 mAh battery and thin metal container and use it as a desktop hotplate/coffee warmer. That's not exactly what I had in mind when I ordered it though, soooo any suggestions would be greatly appreciate.  Big Grin

RE: PBP green LED works but blank display. - KC9UDX - 02-22-2023

Most likely you got a Manjaru update that doesn't work.
And since Manjaru comes with a funky U-Boot that won't boot to micro-SD, you'll need to disable the eMMC to boot to one.