Question regarding odd startup behaviour - Printable Version

+- PINE64 (
+-- Forum: ROCKPRO64 (
+--- Forum: General Discussion on ROCKPRO64 (
+--- Thread: Question regarding odd startup behaviour (/showthread.php?tid=17690)

Question regarding odd startup behaviour - Mff - 12-03-2022

I've got a question regarding a cool RockPro64 4GB board I recently acquired (the previous owner ran it once, concluded it was too much hassle compared to a RPI4 and sent it to me. It worked fine at his place before sending it to me);

When powered the only thing it does, regardless of peripherals connected or storage present, is flash the white LED and one of the ethernet LEDs continuously at something around 2-3Hz. I tried many things; different microSD cards, different card readers, different distros. I also tried disabling the SPI flash by grounding the clock pin; also results in the same behavior. When powered during this behavior the 5V GPOI pin is a steady 5V but the 3.3V seems to be "flashing" together with the LEDs as well.

Finally I tried hooking up the UART2 slot to a usb->UART adapter in order to maybe get something out of the board in that way. Nothing was showing on the UART output, but when I looked back at the RockPro64 suddenly the LED flashing pattern had changed. The board was booting up!

It turns out that I can reliably and  turn on the board (from a powered but "blink-looping") state by connecting the UART pins to a powered UART USB controller, but nothing else! (rebooting always seems to work fine, so only starting from a turned off state is problematic) Connecting either of the UART pins (8 or 10) to ground or the 3.3V volt supply doesn't start it either. 

I updated the firmware via the armbian-config menu, but that doesn't seem to make a difference.

Does anyone have any idea what might be causing this behavior? Is some kind of memory corrupted perhaps? perhaps a somewhat faulty 3.3V circuit? a short? Visually the board seems fine.

Any help in diagnosing this odd behaviour is welcome! Thanks in advance