No audio on Pinebook Pro with Fedora? - Printable Version

+- PINE64 (
+-- Forum: Pinebook Pro (
+--- Forum: Linux on Pinebook Pro (
+--- Thread: No audio on Pinebook Pro with Fedora? (/showthread.php?tid=17193)

No audio on Pinebook Pro with Fedora? - foobar - 08-21-2022

I'm currently running Fedora with tow-boot on my Pinebook Pro, and mostly it's working great. One issue I haven't resolved yet that is specific to this distro, is lack of sound. I get the following errors on boot:

Aug 21 18:11:28 fedora alsactl[1161]: alsa-lib main.c:1541:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -2
Aug 21 18:11:28 fedora alsactl[1161]: /usr/sbin/alsactl: set_control:1475: Cannot write control '2:0:0:ALC Capture Target Volume:0' : Invalid argument

I tried installing a kernel with patches from Manjaro via `kernel-pbp` fromĀ this Copr repo, but it requires a change to the boot procedure, possibly by uninstalling efi, grub and other packages, then installing the u-boot pacakge from that same repo. I'm tempted to try this, but would prefer not to make such radical changes to the boot process at this time. I did try installing their `pinebookpro-audio` package, but that wasn't enough to solve the issue.

Has anyone had any success with audio on Fedora?

RE: No audio on Pinebook Pro with Fedora? - snorwood - 08-22-2022

I have the same issue. Don't quote me on this, but I believe that it worked with the default Fedora 36 installation and broke when I yum updated it. I haven't spent any mount of time trying to troubleshoot this, but figured that I'd post to indicate that you are not the only one with this issue.