PP keyboard not working at all - Printable Version

+- PINE64 (
+-- Forum: PinePhone (
+--- Forum: PinePhone Software (
+---- Forum: Mobian on PinePhone (
+---- Thread: PP keyboard not working at all (/showthread.php?tid=17049)

PP keyboard not working at all - jojuma - 07-23-2022

Today my PP keyboard arrived, but doesn't work.
Since it's charging my PP, i suppose, the connection of the pins is fine.

Now I read in the instructions post, I need the KB151 driver. But before I reinstall the whole system, this results in the following questions:
1. How can I check, if this driver is present?
2. If it isn't, can I install it or do I have to reinstall the whole OS?
3. If I do have to reinstall the whole OS, how do I know if the kernel does include this driver (I read, that in stable, the driver is not present)?

Thanks for helping me

RE: Help with PP keyboard - grump_fiddle_reinstall - 07-24-2022

Try updating to the latest version of mobian. There were kernels without drivers for a while in May.


Although at the moment it is possible that a later update has affected charging and reporting of battery levels.

RE: Help with PP keyboard - jojuma - 07-24-2022

Thanks for your answer.

I am on the latest stable version. The other threads don't have a final solution as it seems.
In one thread is said, that it works now with the latest version, but with the latest version of what? That isn't mentioned (I asked there, too).

sudo modprobe kb151 tells me, that kb151 isn't there. The question remains: can I install that driver or must it be part of the kernel? Do I have to flash a version of the OS whose kernel contains it?

Thanks again

RE: Help with PP keyboard - jojuma - 08-03-2022

I don't know what I did, but it seems to work now. I didn't do anything special. But after another reboot it suddenly worked. Thanks. I'll mark this as solved.