Mobile data suddenly gone - Printable Version

+- PINE64 (
+-- Forum: PinePhone (
+--- Forum: General Discussion on PinePhone (
+--- Thread: Mobile data suddenly gone (/showthread.php?tid=16693)

Mobile data suddenly gone - epiii2 - 05-21-2022

I've been using my new PinePhone for about a week, and then this morning I noticed my mobile data connection wasn't working.  Calls and texts are still fine, but, no internet.  I don't know if it's a firmware/hardware/service issue, but I'm pretty sure it's not software because I've tried multiple OSs and they're all showing this problem now.

Poking around using typical Linux commands I see that the wwan0 interface is down, but I'm clueless about layers deeper than that, once it gets into modem territory.

    $ ip addr show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet scope host lo
          valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host
          valid_lft forever preferred_lft forever
    2: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether 02:ba:7d:21:84:a4 brd ff:ff:ff:ff:ff:ff
        inet brd scope global dynamic noprefixroute wlan0
          valid_lft 3554sec preferred_lft 3554sec
        inet6 fe80::86f8:29c8:ddf7:df8b/64 scope link noprefixroute
          valid_lft forever preferred_lft forever
    3: wwan0: <POINTOPOINT,MULTICAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 1000

Any ideas?  This is with Verizon in the US with a PinePhone revision 1.2b.

RE: Mobile data suddenly gone - epiii2 - 05-23-2022

I fixed it!

...though I'm not sure how.  I had flailed around trying a bunch of AT and qmicli commands and eventually just switched my Access Point in the Settings UI from "Verizon" (no APN text shown?) to "4G LTE Contract" ("vzwinternet") and it started working.  I don't remember changing that setting while troubleshooting but possibly I did.  In any case it seems OK now.

I'm still a bit confused about what the AT commands tell me versus the graphical interface for this stuff so I'm curious if anyone knows about these details.

Using AT+CGDCONT? gives me this:

+CGDCONT: 1,"IPV4V6","ims","",0,0,0,0
+CGDCONT: 2,"IPV4V6","VZWADMIN","",0,0,0,0
+CGDCONT: 3,"IPV4V6","","",0,0,0,0
+CGDCONT: 4,"IPV4V6","VZWAPP","",0,0,0,0
+CGDCONT: 6,"IPV4V6","VZWEMERGENCY","",0,0,0,1

While the Settings app under Manjaro+Phosh shows me:

4G LTE Contract    vzwims
4G LTE Contract    vzwapp
4G LTE Contract    vzwinternet

(What are all these different entries, and where is the Settings thing pulling its somewhat-different info from?)