Constant RockPro64 PCIe SATA Issues - Printable Version

+- PINE64 (
+-- Forum: ROCK64 (
+--- Forum: General Discussion on ROCK64 (
+--- Thread: Constant RockPro64 PCIe SATA Issues (/showthread.php?tid=15823)

Constant RockPro64 PCIe SATA Issues - Kwarter - 01-22-2022

Howdy all,

I got a RockPro64 (4GB model) a while back and intended to use it as a NAS/Plex server.

Some info:
Running: Armbian Buster (Linux 5.10.63-rockchip64)
With: OpenMediaVault 5.6.21-3

I have had constant on and off issues getting my 6TB Seagate Ironwolf HDD to work with the RP. At first, I thought it might be the SATA card, so I replaced the Pine64 one with this card:

That worked for a few months, but then randomly the disk stopped showing up in the OMV filesystems menu. The disk still shows up in lsblk (sda):
rockpro64:/:% lsblk
sda           8:0    0  5.5T  0 disk
mtdblock0    31:0    0   16M  0 disk
mmcblk1     179:0    0 29.7G  0 disk
└─mmcblk1p1 179:1    0 29.4G  0 part /
But the partition is unable to be found.

The disk now makes strange clicking noises when it powers on (brand new HDD by the way), and the noises don't match other HDD failure sounds I've seen posted on YouTube and other places.

I thought it might be due to insufficient power, so I replaced the 12V/5A PSU with a 12V/7.5A PSU, since some people had mentioned that worked for them. The drive label says that it only needs 1A, so the original 5A supply should have been more than sufficient.

To summarize:
  • 6TB 3.5" HDD was working fine for months with the original Pine64 power supply and the SATA adapter listed above.
  • The drive stopped working and even though it shows up in lsblk, the partition is missing and the drive makes strange noises when powering on.

What I've Tried:
  • Replacing the SATA card
  • Replacing the power supply
  • Replacing the SATA cable

Any ideas? I have no idea why it would work just fine for months, but then all of a sudden stop. If I plug the drive into my main PC, it reads no problem.