Wrong FN keys after keyboard FW update - Printable Version

+- PINE64 (
+-- Forum: Pinebook Pro (
+--- Forum: General Discussion on Pinebook Pro (
+--- Thread: Wrong FN keys after keyboard FW update (/showthread.php?tid=15130)

Wrong FN keys after keyboard FW update - j4n3z - 10-18-2021

I performed keyboard firmware update for my Pinebook Pro ANSI as described on Pine64 wiki (just performed on Manjaro) and noticed few things.
- during update there were few messages "device not found" but firmware update seems to completed successfully
- after update some keys are behaving differently from their labels
  - Fn + F9 - labeled as Print Screen, behaves as NumLK
  - Fn + F10 - labeled as NumLK, behaves as ScrLK
  - Fn + F11 - labeled as ScrLK, behaves as Pause
  - Fn + F12 - labeled as Pause, behaves as NumLK

The rest of the keyboard is working propperly as it should. Before the update everything worked propperly so I assume this is caused by firmware update itself. Is there any way to narrow these things? I am affraid of messing things up and ending with non-working keyboard.
Thanks in advance!

Wrong FN keys after keyboard FW update - mtlemmonrunner - 10-18-2021

I don’t think it’s the firmware because those keys mapped correctly before I blew away my old Manjaro dist and installed newest repo version and also work with latest. I flashed firmware/kb/tpad w/iso using fork Dragan Simic’s see pine64 wiki pinebook pro firmware section.

It could be something with the incorrect keyboard layout choice in system settings. I selected default keyboard layout for ansi even though my keyboard is iso I just need to know the keys by memory for a few special characters. Oh and I’m US English-UTF-8

Sent from my iPhone using Tapatalk

RE: Wrong FN keys after keyboard FW update - j4n3z - 10-19-2021

I don't think this has to do with Manjaro as it was reinstalled in september (I think). The only thing changed from then is my migration to SwayWM.

The keyboard behaved the same in Plasma X11 and Sway.

My output from setxkbmap -query

rules:      evdev
model:      pc105
layout:     us

I am using Jack Humbert's fork but that should be OK. I think I solved my problem with step-3 - using revised firmware data. For some reason I overlooked that. Now everything looks to behave correctly.