Talos on ROCK64 - Printable Version

+- PINE64 (
+-- Forum: ROCK64 (
+--- Forum: Linux on Rock64 (
+--- Thread: Talos on ROCK64 (/showthread.php?tid=14089)

Talos on ROCK64 - cjyar - 06-03-2021

I'm trying to get Talos working on my oldish Rock64 board. The PCB says, "ROCK64 V2.0 2017." The Talos devs have a distribution for ROCK64, and one of their engineers says he's got it running on a ROCK64 board. His says "V3 2019." His works, mine doesn't. But mine works just fine when it's running Ubuntu.

According to my packet sniffer, my ROCK64 never sends a DHCPDISCOVER packet. But it seems like the ROCK64 thinks it sent one, and it's waiting for a reply that never comes.

Does it seem likely that there's a hardware or firmware difference between V2 and V3 that's preventing the Talos Linux kernel from talking to the ethernet? Or does it seem more likely that I've messed up my network somehow?

I'm attaching two excerpts from the console log running Talos.

RE: Talos on ROCK64 - TRS-80 - 06-03-2021

Have you double checked your OS media and power?  These should be the first 2 things you look at when troubleshooting pretty much any issue, before even going further into some other things you speculate here.  If nothing else than to eliminate them as possibilities.

Following link is for Armbian, but most of it is generally applicable to any SBC.

Don't believe me?  These are so common that we have an entire sub-forum dedicated to them:  And also why this info is mentioned first, right at the top of troubleshooting section (linked above).

RE: Talos on ROCK64 - cjyar - 06-04-2021

(06-03-2021, 08:58 PM)TRS-80 Wrote: Have you double checked your OS media and power?

Thanks for the links, TRS-80. I have 5 identical boards all supplied by PoE splitters from the pine64 store. They're connected via short CAT5e cables to a switch that claims it's delivering 17W out of 150W that it's capable of. So I think I'm good on the power supply.

The ROCK64 is powering a small USB hard drive also. I tried unplugging that and repeating the boot, and I got the same results.

I've tried flashing the SD cards twice: Once from a Mac using dd, and once from Windows using rufus. Still, I just tried again using balena etcher, and I get the same result.

Do you think I've been thorough enough checking the power and media?