SSH From Outside LAN not working - Printable Version

+- PINE64 (
+-- Forum: General (
+--- Forum: Getting Started (
+--- Thread: SSH From Outside LAN not working (/showthread.php?tid=1395)

SSH From Outside LAN not working - nahssclay - 06-15-2016

Hi all. Not sure how many of you have tried to SSH into your pine64 (using debian image) from outside of the LAN. I am unable to do so. Here are some things I have discovered to help.

1. I have a Raspberry Pi that I can SSH into from the outside. I have a router/modem combo from COX and can SSH from the outside and inside the LAN just fine. And strange enough, I don't even have to forward any ports to do this.
2. I tried to open the port on the router and looks like that doesn't matter one way or another.
3. When the RPi is plugged in to the router/modem, when I check the port 22 on a website, I enter my outside LAN IP and scan port 22 opens. When I remove the RPi and scan again port 22 closes.
4. With the pine64, I have the SSH setup. I can ssh to it from inside my lan network. Can't access outside my LAN.
5. Ran nmap
sudo nmap -p22 **outside LAN IP**
 on my pine64 and it says port 22 is filtered. Now I haven't checked if it says open with RPi only attached to the router/modem but will try that.

6. Ran tcpdump
tcpdump -i eth0 port 22 -n -Q inout

and it doesn't even detect traffic at all, so then I think it's a router issue.
I'm trying every trick I can think of. Anyone have some ideas as to what is going on? If you need more info, just ask! Thanks for the help in advance!