WiFi - Can see networks, not connecting - Printable Version

+- PINE64 (
+-- Forum: General (
+--- Forum: Getting Started (
+--- Thread: WiFi - Can see networks, not connecting (/showthread.php?tid=1340)

WiFi - Can see networks, not connecting - TexasSwede - 06-11-2016

I got my Pine A64 last week, and today I finally unpacked it.
I connected the BT/WiFi module, plugged in a monitor and a keyboard and booted up the Android build supplied in the box.
Everything booted nice and fast. I went into the settings, enabled WiFi and selected my home network. I was able to see all surrounding networks  (not our high speed 5GHz access point but the older 2.4GHz showed up fine), so I entered the password and hit connect.
I very briefly saw first "Connecting...", followed by "Authenticating" and then "Saved". It never said connected.
I double and triple checked the password (I know it very well), I turned wifi off and on again, tried to reconnect... Nothing.
I tried entering a static IP address instead of using DHCP. Still nothing.

Anyone have an idea what to do? The BT part seems to be working, at least it can see different devices. I haven't tried to actually connect to any.
I have tried with both BT on and off.

Update: Eventually I got a status message saying "WiFi Connectivity Failed" or something similar.

Update 2: I enabled wifi hotspot on my mobile phone, and then it connected fine, bot when I set it up as Open and using WEP2 PSK. So it seems to be a problem with my router (from Time-Warner). I guess that is a project for tomorrow...