PINE64
Linux mobian 5.11-sunxi64 -> GREAT! ... or not? - Printable Version

+- PINE64 (https://forum.pine64.org)
+-- Forum: PinePhone (https://forum.pine64.org/forumdisplay.php?fid=120)
+--- Forum: PinePhone Software (https://forum.pine64.org/forumdisplay.php?fid=121)
+---- Forum: Debian on PinePhone (https://forum.pine64.org/forumdisplay.php?fid=139)
+---- Thread: Linux mobian 5.11-sunxi64 -> GREAT! ... or not? (/showthread.php?tid=13278)

Pages: 1 2


Linux mobian 5.11-sunxi64 -> GREAT! ... or not? - scholbert - 03-01-2021

Hi folks,

it's so nice to see that the Mobian team decided to include the latest patches for PD and other useful stuff.
To avoid double posting refer to my post here:
https://forum.pine64.org/showthread.php?tid=13263&pid=90802#pid90802

Just made a short test with one of my type C chargers which was limited to 0.5A before...
Now it got recognized as 3.0A charger.
Will test with another dock tomorrow.

Things get better everyday!
Thanks to the Mobian guys (and to megous of course) for this improvement.

Cheers,
scholbert


RE: Linux mobian 5.11-sunxi64 -> GREAT!! - dcinoz - 03-01-2021

(03-01-2021, 04:34 PM)scholbert Wrote: Hi folks,

it's so nice to see that the Mobian team decided to include the latest patches for PD and other useful stuff.
To avoid double posting refer to my post here:
https://forum.pine64.org/showthread.php?tid=13263&pid=90802#pid90802

I had tried 5.11 a while back but got a black / blank screen on boot.
Just like I later did with Manjaro Plasma Mobile. Screen brightness gets set to a very low value = black on my Pinephone v1.2
If you have wifi and ssh enabled:

Code:
sudo su
echo 400 > /sys/class/backlight/backlight/brightness
will allow you to see the screen.


RE: Linux mobian 5.11-sunxi64 -> GREAT! ... or not? - scholbert - 03-03-2021

Hi,

no problem with the screen brightness here (btw. i'm on V1.2b mainboard).
But after some hours and usage, i have to admit: One step forward and one step back...

- PD works much better now, as the latest patches of megous had been applied
- unfortunately my HDMI multi adapter (Apple) still does not work as expected (0.5A charging only)
- the nasty issue with "modem is gone after sleep" is back on my device.

During the last weeks, while i was on 5.10 Kernel and had updated eg25-manager, this issue has gone...
To realize that it's getting unstable again is really annoying...

Let's see what happens next Confused 

Regards,
scholbert


RE: Linux mobian 5.11-sunxi64 -> GREAT! ... or not? - fernando_c_m - 03-04-2021

@dcinoz Thank you for reporting this. I have normally the brightness in Phosh at the lowest level. If I hadn't set the brightness to a higher level prior to rebooting, I am sure I would have run into the same issue you have.
@scholbert a-way mentioned in another post that crust was now handled in u-boot. Did you update u-boot by executing u-boot-install-pinephone?

No issues here for two days...


RE: Linux mobian 5.11-sunxi64 -> GREAT! ... or not? - scholbert - 03-04-2021

(03-04-2021, 05:34 AM)fernando_c_m Wrote: @scholbert a-way mentioned in another post that crust was now handled in u-boot. Did you update u-boot by executing u-boot-install-pinephone?

No issues here for two days...

Yeah i know about crust... but i'm sure it's not related, because whole system is up to date.
BTW swichted back to 5.10 kernel and no problem with the modem.
So my guess is there could be some side-effect with some of the drivers on 5.11 kernel... maybe little quirk in the new DTS???

I don't get it, you need a good state of mind with this phone, otherwise it drives you crazy Tongue

Cheers,
scholbert


RE: Linux mobian 5.11-sunxi64 -> GREAT! ... or not? - zborgerd - 03-04-2021

(03-04-2021, 06:10 AM)scholbert Wrote:
(03-04-2021, 05:34 AM)fernando_c_m Wrote: @scholbert a-way mentioned in another post that crust was now handled in u-boot. Did you update u-boot by executing u-boot-install-pinephone?

No issues here for two days...

Yeah i know about crust... but i'm sure it's not related, because whole system is up to date.
BTW swichted back to 5.10 kernel and no problem with the modem.
So my guess is there could be some side-effect with some of the drivers on 5.11 kernel... maybe little quirk in the new DTS???

I don't get it, you need a good state of mind with this phone, otherwise it drives you crazy Tongue

Cheers,
scholbert

Scholbert,
 
What's the safest way to switch back to the default 5.10 kernel on Mobian? Will `sudo apt-get remove linux-image-5.11-sunxi64` just automatically roll it back to 5.10.6+sunxi64-2?


RE: Linux mobian 5.11-sunxi64 -> GREAT! ... or not? - scholbert - 03-04-2021

(03-04-2021, 11:55 AM)zborgerd Wrote: What's the safest way to switch back to the default 5.10 kernel on Mobian? Will `sudo apt-get remove linux-image-5.11-sunxi64` just automatically roll it back to 5.10.6+sunxi64-2?

Hi zborgerd,

i had the 5.10 kernel package still installed.
So it was easy done, by editing the file in /boot/extlinux/extlinux.conf to switch back.

If you got different kernel versions installed on your system, they are listed in extlinux.conf and there's a default setting at the beginning.
You need to modfiy the default setting to point at the kernel you'd like to start.

Anyway it should be possible to re-install 5.10 kernel again:

Code:
sudo apt-get install linux-image-5.10-sunxi64

Afterwards check the file extlinux.conf, as mentioned above...
If you have further questions don't hesitate.

Regards,
scholbert


RE: Linux mobian 5.11-sunxi64 -> GREAT! ... or not? - zborgerd - 03-04-2021

Thanks.  That's all I needed. Removing the 5.11 kernel automatically made 5.10 the default l0 entry.


RE: Linux mobian 5.11-sunxi64 -> GREAT! ... or not? - dukla2000 - 03-04-2021

(03-04-2021, 05:34 AM)fernando_c_m Wrote: ...
Did you update u-boot by executing u-boot-install-pinephone?
...

Thanks for the reminder.

Installed the kernel itself a couple of days ago - thanks for the pointers @scholbert . No major issues that I've noticed yet, except not (yet) compatible with CRUST in megi's latest p-boot. No matter - booting fine and sleep mode fine using p-boot's eMMC option.

No other excitement with brightness nor dongle (only used for USB pendrive & Ethernet). Don't have a proper PD charger to fret about charging power.

Did notice USB charging mode settles a lot quicker (ANX driver?) than before. Previously with Mobian 5.10 kernel often seemed to land in the 3 minute recycle loop before settling down to charge when plugging in to my dongle.


RE: Linux mobian 5.11-sunxi64 -> GREAT! ... or not? - scholbert - 03-08-2021

Hi again,

i'd like to note that there had been some further patches/reworks applied on 5.11 release. Now hitting 5.11.3 version.
Especially this seems interesting:
https://gitlab.com/mobian1/devices/sunxi64-linux/-/commit/37116a296030109004d516171258684241653676

Thanks a lot to a-wai for stepping again through the whole patchset...
Impressive work!!

So i guess i'll give it a try again... and hopefully my issue with the modem part on 5.11 got fixed now.

EDIT:
O.K. so had to go back to 5.10 again...

In the end two things with the new 5.11 kernel, that drive me nuts:
- modem got lost after sleep (this is reproducable, if i switch back to 5.10 it's gone)
- jitterentropy service goes mad or hangs and gives 100% system load (same here, reproducable, if i switch back to 5.10 it's gone)

Anyone else observing these issues.
I guess i'll have to join the bug tracker...
Thought as well about a clean re-install of a nightly image, though my installation should be in good shape.
Nothing went wrong with the installs and setups in the past.
Sometimes i think, some parts of systemd are not set up properly or there are some race conditions with other services.

But i don't want to mix up things here... sadly the new kernel is not ready for me yet.


Regards,

scholbert