PINE64
VoLTE calls with o2 (Germany) - Printable Version

+- PINE64 (https://forum.pine64.org)
+-- Forum: PinePhone (https://forum.pine64.org/forumdisplay.php?fid=120)
+--- Forum: General Discussion on PinePhone (https://forum.pine64.org/forumdisplay.php?fid=127)
+--- Thread: VoLTE calls with o2 (Germany) (/showthread.php?tid=12984)



VoLTE calls with o2 (Germany) - arno_nuehm - 02-03-2021

Hello there,

did anyone manage to set up VoLTE calls with o2 (Germany)?

In my case (Mobian), the modem was automatically set to Telefónica Germany but the phone always switches to 3G for calls.

I'm curious, if other distros can do VoLTE calls with o2 (Germany) and if anyone could provide some help.

Thanks in advance!


RE: VoLTE calls with o2 (Germany) - synQun - 02-03-2021

This are maybe some good news to you. For me VoLTE on German Telefonica network is so far working well and I got an superior call audio quality.
I'm using pmOS edge on a Ubports CE with a Simplytel sim card by Drillisch. Reception indoors is sometimes problematic but otherwise fine.

As far as I know pmOS is using some AT Commands to select a custom VoLTE profile and sets my APN setting for mobile data automatically.
Their wiki gives you more information about how they are doing it and there is even a request to enable it in Mobian in the near future.
If I were you, I would try to follow their instructions and put them in startup script that is executed on boot. See the Mobian =rc]wiki for a way to do so.

Since I also got only 2G calls while I was using MedionMobile, it is possible that some cheaper providers are not able to do VoLTE on Telefonica Network.
From your post I understand that you are using a O2 plan and should get VoLTE. If above steps are working, please report back on the Mobian to get this merged more quickly.


RE: VoLTE calls with o2 (Germany) - arno_nuehm - 02-05-2021

(02-03-2021, 08:35 AM)synQun Wrote: This are maybe some good news to you. For me VoLTE on German Telefonica network is so far working well and I got an superior call audio quality.
I'm using pmOS edge on a Ubports CE with a Simplytel sim card by Drillisch. Reception indoors is sometimes problematic but otherwise fine.

As far as I know pmOS is using some AT Commands to select a custom VoLTE profile and sets my APN setting for mobile data automatically.
Their wiki gives you more information about how they are doing it and there is even a request to enable it in Mobian in the near future.
If I were you, I would try to follow their instructions and put them in startup script that is executed on boot. See the Mobian =rc]wiki for a way to do so.

Since I also got only 2G calls while I was using MedionMobile, it is possible that some cheaper providers are not able to do VoLTE on Telefonica Network.
From your post I understand that you are using a O2 plan and should get VoLTE. If above steps are working, please report back on the Mobian to get this merged more quickly.

Thanks for your answer. Since my modem is already set to

Code:
+QMBNCFG: "List",9,1,1,"TF_Germany_VoLTE",0x05010C1B,201909201

indicated by the two "1"s, it seems I'll have to wait for the new modem driver and see, if this brings me VoLTE.


RE: VoLTE calls with o2 (Germany) - TRS-80 - 02-05-2021

Really glad to hear there is at least some hope of VoLTE working! It's something I have been worrying about on the horizon...

Of course, things are different here in US. Maybe I should find another thread about that more specifically (or make one).

Cheers!


RE: VoLTE calls with o2 (Germany) - arno_nuehm - 03-07-2021

Finally...

After a long period of trial&error, my VoLTE with o2 (Germany) works on Mobian. And it was quite easy after all...

Here is what I did:

Disable VoLTE profile autoselection

Code:
mmcli -m any --command='AT+QMBNCFG="AutoSel",0'

Select the generic VoLTE profile

Code:
mmcli -m any --command='AT+QMBNCFG="Select","ROW_Generic_3GPP"'

Restart the modem

Code:
mmcli -m any --command='AT+CFUN=1,1'

Check the selected VoLTE profile with

Code:
mmcli -m any --command='AT+QMBNCFG="List"'

Check the VoLTE status with

Code:
mmcli -m any --command='AT+QCFG="ims"'

--> response should be
Quote:'+QCFG: "ims",1,1'


if it shows "1,0", checking and disabling the phone's "Aeroplane Mode" might help (it was magically on after the reset in my case)

Change the Network Mode in "Settings - Mobile" to "4g Only" and make a test call. It should work.


Cheers!


RE: VoLTE calls with o2 (Germany) - asz - 06-09-2021

Hi guys.

I followed you thread and gathered enough hope to try it again. I have tried before to no avail, and this time it ended as the last.

Whatever I configure my modem to do, it does not enable VoLTE but switches to 3G, loses its signal (because 3G i weak) and fails the call.

Any suggestion to wjat I can try?

Oh, and when I try the same SIM in my "moto 8G" with android, it does VoLTE like a charm....sigh. I really want to use my pinephone.

Cheers!