Pinebook Pro has become dead, no lights? - Printable Version

+- PINE64 (
+-- Forum: General (
+--- Forum: General (
+--- Thread: Pinebook Pro has become dead, no lights? (/showthread.php?tid=12840)

Pinebook Pro has become dead, no lights? - JohnKarpenter - 01-21-2021

Hi people

I've had a PBP working successfully for a month or so. But now it's dead.

It's sat in an inmoving position, connected to the mains with the barrel charger which I switch on from time to time to top up the battery. It's mostly used for flashing to my pinephone so it's not been used heavily, I also have tried a few OS's so it has been booting from multiple SD cards and the emmc (from original Manjaro) successfully.

Yesterday I flashed opensuse to the emmc (booted and rebooted a few times) and decided it wasn't for me so I flashed Manjaro again but after I tried to reboot it crashed so I had to force shutdown with 10s hold on power button. After that it failed to start up (no lights on front but charger is lit red when plugged in).

After leaving it for an hour or so it started, but after a reboot it went back to dead. And next day that's how it still is.

As it's not been moving it's unlikely to be a loose cable inside so I hesitate to take the back cover off.

Are there any known issues that may help me? Could repeated plugging of mains/SD/USB cause this?VidMate Mobdro

RE: Pinebook Pro has become dead, no lights? - tophneal - 01-21-2021

Have you test the reliability of booting ext media with the emmc switched off yet?

RE: Pinebook Pro has become dead, no lights? - KC9UDX - 01-21-2021

Do try that: Manjaro and the U-boot that comes with it seem to cause exactly these symptoms, frequently.

Also reported as of late was a dead wall wart (barrel charger) so if you can, try USB-C.

RE: Pinebook Pro has become dead, no lights? - TfromTexas - 07-01-2021

Quote:My Pinebook Pro is dead and I don't know why and what to do with it. I rebooted it yeasterday, after it refused to work as I was about to do my homework online for a same day class. It went back to dead after a reboot.

Hi John,

Can you use your waranty? How long is it? You should definitely try a USB-C charger so that you could bring up your battery high enough.