touchpad on pinebook issues? - Printable Version

+- PINE64 (
+-- Forum: Pinebook (
+--- Forum: Pinebook Hardware and Accessories (
+--- Thread: touchpad on pinebook issues? (/showthread.php?tid=12553)

Pages: 1 2

touchpad on pinebook issues? - ron_burgundy - 12-17-2020

11 inch OG pinebook here on kde neon. 

touchpad works fine, but i have no scroll or tap click function. is that by design? I see that it is recognized as a regular mouse, could that be the issue? not sure if there is a fix or if thats just how it is.

any help would be greatly appreciated

RE: touchpad on pinebook issues? - KC9UDX - 12-17-2020

Which operating system?

synaptics or libinput?

RE: touchpad on pinebook issues? - ron_burgundy - 12-17-2020

Oh man I thought kde neon with plasma was the os? haha.

And not sure whether synaptics or libinput either

If I check system information it says ubuntu 18.05.5 LTS bionic beaver

Under system settings it says I have a mouse but no more info than that.
Any idea how I would find out more?

Also thank you for taking the time to help me out.

RE: touchpad on pinebook issues? - KC9UDX - 12-17-2020

I wish I could help, but I'm not really a Linux user. And we don't have this capability in NetBSD yet that I can see. I've been researching how to get it working in NetBSD, and found a bunch of information on Linux. Apparently sometimes at least, if you're using the synaptics driver, there is a configuration file. And at least some versions of libinput don't support this functionality.

Hopefully someone with better information comes along.

RE: touchpad on pinebook issues? - ron_burgundy - 12-17-2020

Yeah well thanks for giving it some thought. If you couldn't tell I'm pretty new to all this. Need all the help I can get.

Again, thanks for taking the time

RE: touchpad on pinebook issues? - KC9UDX - 12-17-2020

I did a DuckDuckGo search "Linux touchpad" and got a lot of decent results. This one looks promising. It's Kali Linux, but might apply to Ubuntu as well.

RE: touchpad on pinebook issues? - jezek - 12-18-2020

I have tried more distros with pinebook 1080p 11" and in none of them worked the tap-to-click. I've tried both synaptics and libinput, different configurations, still no tap-to-click. Someone on this forum said to me, that tap-to-click is working for him, but I newer got any instructions from him, that worked for me.

The scroll worked for me on every distro I tried, but only the two-finger-scroll, which is sometimes mishandled as pinch-to-zoom (I failed to turn off the pinch-to-zoom too). So I try to avoid of using the touchpad and use the Manjaro Sway Profile. In my opinion it is the most fastest & usable distro/version for pinebook till now.

Edit: If you (or someone) figure out how to enable tap-to-click,and/or disable pinch-to-zoom, please write me. Thank you.

RE: touchpad on pinebook issues? - KC9UDX - 12-18-2020

I find this odd; multi-touch scroll and zoom should be much more difficult than tap-to-click.

In KDE, do you have System Settings -> Input Devices -> Touch pad? (I do not)

RE: touchpad on pinebook issues? - ron_burgundy - 12-18-2020

a usb mouse is listed and seems to be in use, but under the touchpad settings it says no touchpad connected.

Weird that others seem to be able to scroll, I tried two finger and everything no dice. I also cannot make it pinch to zoom either not sure what the deal is. Going to look into the kali tutorials link posted above when I get a chance.

Anyway as usual thanks for the input everyone.

RE: touchpad on pinebook issues? - KC9UDX - 12-18-2020

This might be better than the Kali one (not sure):

This is the dead end I run into; the synaptics driver will not work as is on NetBSD (yet).