PBP lines across screen, halts whilst running (prev. will not power on) - Printable Version

+- PINE64 (
+-- Forum: Pinebook Pro (
+--- Forum: Pinebook Pro Hardware and Accessories (
+--- Thread: PBP lines across screen, halts whilst running (prev. will not power on) (/showthread.php?tid=10420)

PBP lines across screen, halts whilst running (prev. will not power on) - ajcollins - 06-25-2020


After a hardware failure on my primary laptop last week (display backlight failure), I was looking forward to more time using my PBP, which has had minimal use to date.

This morning, the screen started displaying various horizontal lines and obviously corrupt data, and the device became unresponsive. Was booted off SD (Manjaro, i3wm) at the time.

Power-off worked. Power-on did not. I've tried leaving to charge, and battery bypass, with no success.

I am using an Apple USB-C charger, which continues to work correctly with other Apple / Dell devices. I have not tried the PSU which came with it as it didn't come with a UK adaptor and I do not have one.

My PBP is from the second batch, I believe, has the 128GB eMMC, and arrived in mid-November.

From looking over other posts, it looks like the options to explore are:
- Removing the eMMC / toggling the switch;
- Connecting a serial cable (I do not think I have a compatible one) to check whether uBoot is loading.

Any other suggestions I have missed?

Thank you!

RE: PBP will not power on - ajcollins - 06-25-2020

Now turning on and booting having:
- Physically unplugged battery;
- Removed and re-seated the eMMC.

One hinge spacer was cracked upon opening the case the first time (assumed over tightening on initial assembly?). Care is needed with the speakers during disassembly - one of the wires departed the speaker upon opening as the sticky tape didn't stick well to the case, but stuck very well indeed on the table top.

RE: PBP will not power on - ajcollins - 06-25-2020

Marking as not fixed.

I left the PBP running htop. Unfortunately it reverted to displaying horizontal lines and being unresponsive within an hour. Again whilst running Manjaro i3wm off of the SD card.

Issue continue when booting the pre-installed Debian image from eMMC. PBP powers on, displays a number of short red horizontal lines, then goes unresponsive. Line occasionally flicker, but boot does not continue

Any ideas?.

RE: PBP will not power on - Alstroplane - 07-01-2020

The PBP has an almost distict way to boot, its 5 seconds off, 3 missipi on,
I thought the pre installed was Manjaro, ARM based not debian?

Have you flashed your emmc or is this out of the box while using an sd card?
If you flashed your emmc already it may that you installed an incorrect vesion for the PineBook Pro, known working versions can be found here:
I had a similiar probelm when flashing Arch, I used the wrong version, it booted but only to a gub menu, once flashing the correct Pinebook Pro version it booted.

Here is the link to the official supported distro versions for the PinebookPro

RE: PBP will not power on - xmixahlx - 07-02-2020

grab a new sdcard and make a sdcard install for emergency recovery use.

i use a modified danielt debian installer.

if it doesnt boot, then the emmc bootloader is probably toast. switch off the emmc and test again.

if that works, then boot the sdcard again and switch on the emmc quickly at boot (at light).

use the unbind+bind script to enable the emmc in userspace. see wiki or pbp-run-reset-emmc in pbp-tools

backup data from emmc and write a new install to emmc.

RE: PBP lines across screen, halts whilst running (prev. will not power on) - ajcollins - 07-05-2020

Thank you for your replies. I have updated the title as it was now misleading as to the primary problem.

Earlier builds were not Manjaro. That is a more recent change.

SD card is fine, EMMC appears fine. Behaviour is the same irrespective of boot source.

I believe this is a hardware issue.

The machine will boot and run for a short while (from seconds to a few minutes). The display will then show various corrupt / garbage lines, and the machine will stop responding.

Possibly thermal-related; if it warms up the non-power on behaviour temporarily returns.

As the plastics are also breaking already despite minimal use, and as I’ve not got spare time for debugging the hardware, this will sadly be consigned to e-waste. Hopefully the other parts can be used for something else.