PINE64

Full Version: libgl1-mesa-dev has unmet dependancies
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have the rock64 4gb board with bionic-lxde-rock64-0.7.8-1061-arm64.img installed. Did apt-get update and upgrade,  Trying to install gr-hpsdr with the error as follows :
Code:
The following packages have unmet dependencies:
libgl1-mesa-dev : Depends: libglvnd-dev but it is not going to be installed
linux-rock64 : Depends: board-package-rock64-0.7-30 but it is not going to be installed
               Depends: u-boot-rockchip-rock64-2017.09-rockchip-ayufan-1025-g482cd6ec8b but it is not going to be installed
               Depends: linux-image-4.4.132-1075-rockchip-ayufan-ga83beded8524 but it is not going to be installed
               Depends: linux-headers-4.4.132-1075-rockchip-ayufan-ga83beded8524 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
I have tried apt  --fix-broken install, same error as above, also apt-get install linux-rock64 -y, still same error of unmet dependencies. Also tried apt-get install -f, with following:
Code:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
 libglvnd-dev
The following NEW packages will be installed:
 libglvnd-dev
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
53 not fully installed or removed.
Need to get 0 B/3412 B of archives.
After this operation, 25.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 86638 files and directories currently installed.)
Preparing to unpack .../libglvnd-dev_1.0.0-2ubuntu2.2_arm64.deb ...
Unpacking libglvnd-dev:arm64 (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_arm64.deb (--unpack):
trying to overwrite '/usr/lib/aarch64-linux-gnu/libEGL.so', which is also in package libmali-rk-utgard-450-r7p0:arm64 1.6-1ayufan10
Errors were encountered while processing:

Cannot get this corrected, even reformatted and reinstalled img, retried the hpsdr install after all updates. Does anyone have or know the fix to this?
(01-06-2019, 10:30 PM)jr864 Wrote: [ -> ]I have the rock64 4gb board with bionic-lxde-rock64-0.7.8-1061-arm64.img installed. Did apt-get update and upgrade,   Trying to install gr-hpsdr with the error as follows :
Code:
The following packages have unmet dependencies:
libgl1-mesa-dev : Depends: libglvnd-dev but it is not going to be installed
linux-rock64 : Depends: board-package-rock64-0.7-30 but it is not going to be installed
               Depends: u-boot-rockchip-rock64-2017.09-rockchip-ayufan-1025-g482cd6ec8b but it is not going to be installed
               Depends: linux-image-4.4.132-1075-rockchip-ayufan-ga83beded8524 but it is not going to be installed
               Depends: linux-headers-4.4.132-1075-rockchip-ayufan-ga83beded8524 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
I have tried apt  --fix-broken install, same error as above, also apt-get install linux-rock64 -y, still same error of unmet dependencies. Also tried apt-get install -f, with following:
Code:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
 libglvnd-dev
The following NEW packages will be installed:
 libglvnd-dev
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
53 not fully installed or removed.
Need to get 0 B/3412 B of archives.
After this operation, 25.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 86638 files and directories currently installed.)
Preparing to unpack .../libglvnd-dev_1.0.0-2ubuntu2.2_arm64.deb ...
Unpacking libglvnd-dev:arm64 (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_arm64.deb (--unpack):
trying to overwrite '/usr/lib/aarch64-linux-gnu/libEGL.so', which is also in package libmali-rk-utgard-450-r7p0:arm64 1.6-1ayufan10
Errors were encountered while processing:

Cannot get this corrected, even reformatted and reinstalled img, retried the hpsdr install after all updates. Does anyone have or know the fix to this?


Hope that a solution is in the works ... or work around ....
[email protected]:~/Downloads/sdrangel/build$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
libopts25
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
libglvnd-dev
The following NEW packages will be installed:
libglvnd-dev
0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
163 not fully installed or removed.
Need to get 0 B/3412 B of archives.
After this operation, 25.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 116454 files and directories currently installed.)
Preparing to unpack .../libglvnd-dev_1.0.0-2ubuntu2.2_arm64.deb ...
Unpacking libglvnd-dev:arm64 (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_arm64.deb (--unpack):
trying to overwrite '/usr/lib/aarch64-linux-gnu/libEGL.so', which is also in package libmali-rk-utgard-450-r7p0:arm64 1.6-1ayufan10
Errors were encountered while processing:
/var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~/Downloads/sdrangel/build$