PINE64

Full Version: A64+ vs. A64-LTS - Build boots?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi all,
I accidentally booted my A64-LTS with the A64+ Debian image, and it booted fine and everything seemed to work. From reading, I had thought the SOPine build was completely different than the A64+ and would not be interchangeable, yet this doesn't appear to be the case.

Could you kindly explain to me the actual difference? Like, is there a risk involved in interchanging the SD card between A64+ and the A64-LTS?

I'm actually a bit surprised/confused as I thought it would not boot if I installed the wrong platform's OS on the wrong board.

Thanks for helping clarify my brain!  Tongue

Robbie
the memory is different on the 64/64+/64LTS than the sopine. the 64/64+ and 64LTS have the same memory hence the same builds. the 64LTS is not the sopine.
Thanks you, dkryder - though I am unclear what your answer means in light of my question.

http://wiki.pine64.org/index.php/SOPINE_...re_Release says "Note that, SOPINE OS images are also compatible with PINE A64-LTS"

http://wiki.pine64.org/index.php/PINE_A6....2F_SOPINE calls the software section "PINE A64-LTS / SOPINE"

https://www.pine64.org/?page_id=46828 calls it "Pine A64-LTS (Same as SOPINE)" under Software & SDK.

http://wiki.pine64.org/index.php/Main_Pa...t_Guide.5D calls it "PINE A64-LTS / SOPine"

and finally,

http://wiki.pine64.org/index.php/PINE_A64_Main_Page says "Note that PINE A64(+) OS images are not compatible with PINE A64-LTS due to LPDDR3 memory configuration. For PINE A64-LTS OS image downloads please refer to the SoPine and Pine64-LTS Section"

Which leads me back to my question.
yeah, the specs on the store say DDR3 and not LPDDR3 for the LTS. in checking on the net it does have LPDDR3. so, the 2 should share builds. what was the filename of the build you used?
So does that mean the software DOES in fact work on either board, even though the site says otherwise?

I'm using Ayufan's 0.7.19-118 Stretch Minimal build. What's strange though is that Ayufan has both the Pine64 and the SOPINE versions built... so if they're interchangeable, I don't understand why there'd be both Smile

Cheers,
Robbie
https://github.com/ayufan-pine64/linux-b...118.img.xz
https://github.com/ayufan-pine64/linux-b...118.img.xz

these are not the same. sopine works on the sopine . pine64 works on pine64. the LTS should run sopine since it supposedly shares the lpddr3 memory. which one of the above builds did you boot?
The Pine64 build (second one).
strange. maybe they sent you a pine64 instead of the LTS. do you have the emmc slot?
Yes, it's a true LTS. Has eMMC and barrel plug, and says LTS on the board.

I also have an A64+, which is how I made the mistake (they do look the same at a glance) - I had burnt the image to the SD and booted from the wrong board. Build is the Pine64 build, but the LTS booted fine. In fact the LTS had display whereas the A64+ (with the same build) doesn't. I installed a whole bunch of stuff, and then having realized my mistake I moved the SD card to the A64+ and it too booted fine.

Weird, am I right? I mean, I've never purposefully tried it - just going by the docs it should not have worked?
well, pine64+ and sopine will not boot from the others builds. so, i have no idea what is happening with the boards/builds you have. and to be honest , don't care that much at all. i never liked the LTS. i view it as a replay of a piece of junk cpu/gpu combo. who knows maybe they actually put DDR3 on it when price of LPDDR3 got quite expensive. good luck with it.
Pages: 1 2