PINE64

Full Version: DKMS on kernel 3.10.107-pine64
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Attempting to install wireguard using DKMS on Armbian Xenial (legacy kernel). I've apt-installed kernel headers, but DKMS is failing to build the wireguard kernel module with the following error:


Code:
DKMS make.log for wireguard-0.0.20180613 for kernel 3.10.107-pine64 (aarch64)
Wed Jun 20 12:47:41 PDT 2018
make: Entering directory '/usr/src/linux-headers-3.10.107-pine64'
Makefile:581: /usr/src/linux-headers-3.10.107-pine64/arch//Makefile: No such file or directory
make: *** No rule to make target '/usr/src/linux-headers-3.10.107-pine64/arch//Makefile'.  Stop.
make: Leaving directory '/usr/src/linux-headers-3.10.107-pine64'

It looks like something is missing between 'arch/' and '/Makefile' in the target path.

Any ideas? Something obvious I'm missing?
try going into the source directory and typing

make ARCH=arm64
(06-20-2018, 06:01 PM)evilbunny Wrote: [ -> ]try going into the source directory and typing

make ARCH=arm64

 Result - failure, log below. If it helps, this built with no problem using DKMS on H5 3.10.something(I forget) Kernel in a NanoPi Neo2... I believe it was a Xenial build.
Code:
CC [M]  /usr/src/wireguard-0.0.20180613/main.o
In file included from <command-line>:0:0:
/usr/src/wireguard-0.0.20180613/compat/compat.h:218:19: error: redefinition of ‘prandom_u32_max’
 static inline u32 prandom_u32_max(u32 ep_ro)
                   ^
In file included from include/linux/net.h:22:0,
                 from include/linux/skbuff.h:27,
                 from include/linux/ip.h:20,
                 from include/linux/if_tunnel.h:4,
                 from include/net/ip_tunnels.h:4,
                 from /usr/src/wireguard-0.0.20180613/compat/compat.h:83,
                 from <command-line>:0:
include/linux/random.h:48:19: note: previous definition of ‘prandom_u32_max’ was here
 static inline u32 prandom_u32_max(u32 ep_ro)
                   ^
scripts/Makefile.build:308: recipe for target '/usr/src/wireguard-0.0.20180613/main.o' failed
make[2]: *** [/usr/src/wireguard-0.0.20180613/main.o] Error 1
Makefile:1228: recipe for target '_module_/usr/src/wireguard-0.0.20180613' failed
make[1]: *** [_module_/usr/src/wireguard-0.0.20180613] Error 2
Makefile:36: recipe for target 'module' failed
make: *** [module] Error 2
(06-20-2018, 08:44 PM)obrienmd Wrote: [ -> ]
(06-20-2018, 06:01 PM)evilbunny Wrote: [ -> ]try going into the source directory and typing

make ARCH=arm64

 Result - failure, log below. If it helps, this built with no problem using DKMS on H5 3.10.something(I forget) Kernel in a NanoPi Neo2... I believe it was a Xenial build.
Code:
CC [M]  /usr/src/wireguard-0.0.20180613/main.o
In file included from <command-line>:0:0:
/usr/src/wireguard-0.0.20180613/compat/compat.h:218:19: error: redefinition of ‘prandom_u32_max’
 static inline u32 prandom_u32_max(u32 ep_ro)
                   ^
In file included from include/linux/net.h:22:0,
                 from include/linux/skbuff.h:27,
                 from include/linux/ip.h:20,
                 from include/linux/if_tunnel.h:4,
                 from include/net/ip_tunnels.h:4,
                 from /usr/src/wireguard-0.0.20180613/compat/compat.h:83,
                 from <command-line>:0:
include/linux/random.h:48:19: note: previous definition of ‘prandom_u32_max’ was here
 static inline u32 prandom_u32_max(u32 ep_ro)
                   ^
scripts/Makefile.build:308: recipe for target '/usr/src/wireguard-0.0.20180613/main.o' failed
make[2]: *** [/usr/src/wireguard-0.0.20180613/main.o] Error 1
Makefile:1228: recipe for target '_module_/usr/src/wireguard-0.0.20180613' failed
make[1]: *** [_module_/usr/src/wireguard-0.0.20180613] Error 2
Makefile:36: recipe for target 'module' failed
make: *** [module] Error 2


Ok, so you got past the previous problem, try ARCH=armhf or just arm
[quote pid='38663' dateline='1529551443']

Ok, so you got past the previous problem, try ARCH=armhf or just arm
[/quote]

Different failures Smile, aarch64 also no-go:


Code:
[email protected]:/usr/src/wireguard-0.0.20180613# make ARCH=arm
 CC [M]  /usr/src/wireguard-0.0.20180613/main.o
gcc: error: unrecognized argument in option ‘-mabi=apcs-gnu’
gcc: note: valid arguments to ‘-mabi=’ are: ilp32 lp64
gcc: error: unrecognized command line option ‘-msoft-float’
scripts/Makefile.build:308: recipe for target '/usr/src/wireguard-0.0.20180613/main.o' failed
make[2]: *** [/usr/src/wireguard-0.0.20180613/main.o] Error 1
Makefile:1228: recipe for target '_module_/usr/src/wireguard-0.0.20180613' failed
make[1]: *** [_module_/usr/src/wireguard-0.0.20180613] Error 2
Makefile:36: recipe for target 'module' failed
make: *** [module] Error 2

[email protected]:/usr/src/wireguard-0.0.20180613# make ARCH=armhf
Makefile:581: /usr/src/linux-headers-3.10.107-pine64/arch/armhf/Makefile: No such file or directory
make[1]: *** No rule to make target '/usr/src/linux-headers-3.10.107-pine64/arch/armhf/Makefile'.  Stop.
Makefile:36: recipe for target 'module' failed
make: *** [module] Error 2

[email protected]:/usr/src/wireguard-0.0.20180613# make ARCH=aarch64
Makefile:581: /usr/src/linux-headers-3.10.107-pine64/arch/aarch64/Makefile: No such file or directory
make[1]: *** No rule to make target '/usr/src/linux-headers-3.10.107-pine64/arch/aarch64/Makefile'.  Stop.
Makefile:36: recipe for target 'module' failed
make: *** [module] Error 2
(06-21-2018, 08:38 AM)obrienmd Wrote: [ -> ]Different failures Smile, aarch64 also no-go:

Have you tried older/newer versions? or reported your troubles on the wire guard mailing list?