Full Version: Android 6 build
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi guys,

Im new to building images and 
i've been trying to compile android 6 for my PINE LTS.
I used Ayufan's android 6 build and it was compiling fine with the MAKE stating that it was successful after many hours. 

However when i plugged in the board, after changing the uEnv text file, the board did not boot. 
After prowling around for a long time, i found out that my vendor/modules folder in the system partition of the SDcard
seemed to be missing. 

I confirmed this by downloading ayufans "android-6.0-pine-a64-sopine-v1.3.0-r34.img"
and etching it to my sdcard. Upon comparison realizing that i had a missing folder. 

I even copied it over to my system folder in my etched sdcard with my broken build and it booted after that. 

I checked my "android/out/target/product/tulipchiphd/system" folder and /vendor/modules was there and fine, having everything in check.

Would anyone happen to know how this came to be. I didnt use the jenkins file, but i kind of followed the instructions in the jenkinsfile and 
prepared my ubuntu 16 with all the prerequisites found in his dockerfile. To be frank, i initially used jenkins and docker but it didnt boot either. 

On a side note, I tried out the 
Android 6.0.1 [20170726] img from
and it booted and cameras everything worked great (i did not know why the camera did not work for ayufan's build on stock camera app). Would anyone happen to know if they have released sources or if i can try to build this img as well? 

Thanks for any help guys
Big Grin