Full Version: Clusterboard issue: onboard leds off / no boot
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi all!
today i started my clusterboard project but i found the first big problem.
i flashed the memory card with Armbian image, put the Sopine module in his riser, turned the clusterboard on and nothig happens. Confused
All the led near the riser never turns on, the RJ45 leds sometimes blinks for less than a second, but nothig appear connected to my switchport.
The only turned on led is the one on the sopine module..

Is this happened to someone else?
the img that i'm using is Armbian_5.41_Pine64so_Ubuntu_xenial_next_4.14.20.img (working perfectly on LTE board)
tried all the sopine modules with the same result.

Thanks to everyone for help

[Image: KF5jbno.jpg]
Are you using the fixed Armbian image that I uploaded? Or just the one on Armbian's site?
I've partially fixed the problem.. the clusterboard "works" only with an ATX psu, but anyway i'm still having many problems.

I've tried in order:

Build 5.35 from Pine64 Installer

No more than 3 sopine modules works toghether, with 4 no boot at all.
Do you perchance happen to have a uart/serial hookups?
what do you mean sorry?
i know what uart is but i don't understand your question.
(05-10-2018, 04:41 PM)Mark88 Wrote: [ -> ]what do you mean sorry?
i know what uart is but i don't understand your question.

I think they meant did you have one of these...
Sorry I can't see/read, something like that or the below:
And before you ask why... it's because with out it, you can't debug what the heck is going on with the board! Blush

With it you, may be able to glean from the bootup messages what is happening... and we might be better able to understand things like 'no boot at all' ("well, it actually does power up, but it doesn't boot" or "the module power light just flashed when I had more than three plugged in and didn't do anything at all" or "the module does boot, but the darn things all claim they have the same mac address, so my router has a hissy fit", etc, etc).

Basically, without some way of connecting to that serial console, it's hard to debug stuff on ARM based SBCs as there is no BIOS, so no stuff to screen until the system is well and truly loading.
Thank you very much for your clear explanation!
i i'll give you more detailed info about the problem in few days

are both ok?


(05-11-2018, 03:27 PM)Mark88 Wrote: [ -> ]i'll give you more detailed info about the problem in few days

are both ok?

No worries...

I would personally recommend the CH340G as I have had very little trouble with that particular USB to serial chipset. There is nothing wrong with the CP2102 either though, although it should only be able to do 1Mb baud rate instead of the needed 1.5Mb... 

Note that you'll want some linking wires if you don't already have any... just the three... for GND, TX and RX.
Pages: 1 2